aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Richardson2015-01-13 15:49:34 -0800
committerDoug Richardson2015-01-13 15:49:34 -0800
commiteec658b9195e0073d4c0c06f93ae94100d7c5b9c (patch)
tree405b48c23a1c0e3305d0b18682ca26b20f978346
downloadaur-eec658b9195e0073d4c0c06f93ae94100d7c5b9c.tar.gz
package to disable link level multicast name resolution (llmnr)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
-rw-r--r--disable-llmnr.conf4
-rw-r--r--disable-llmnr.install39
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56d29cccfa1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = disable-resolved-llmnr
+ pkgdesc = Disable Link Local Multicast Name Resolution (LLMNR).
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/drichardson/arch_packages
+ install = disable-llmnr.install
+ arch = any
+ license = BSD
+ depends = systemd
+ source = disable-llmnr.conf
+ md5sums = 3f479d07204e3067f62c5e4d6841b790
+
+pkgname = disable-resolved-llmnr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b0a064de6da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Doug Richardson <dougie.richardson@gmail.com>
+# /etc/systemd/resolved.conf.d/*.conf.
+pkgname=disable-resolved-llmnr
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Disable Link Local Multicast Name Resolution (LLMNR)."
+arch=(any)
+url="https://github.com/drichardson/arch_packages"
+license=('BSD')
+depends=(systemd)
+optdepends=()
+backup=()
+changelog=
+install=disable-llmnr.install
+source=('disable-llmnr.conf')
+md5sums=('3f479d07204e3067f62c5e4d6841b790')
+
+package() {
+ install -Dm644 "$srcdir"/disable-llmnr.conf "$pkgdir"/etc/systemd/resolved.conf.d/disable-llmnr.conf
+}
+
diff --git a/disable-llmnr.conf b/disable-llmnr.conf
new file mode 100644
index 000000000000..0677828550d6
--- /dev/null
+++ b/disable-llmnr.conf
@@ -0,0 +1,4 @@
+# See resolved.conf(5) for details
+
+[Resolve]
+LLMNR=no
diff --git a/disable-llmnr.install b/disable-llmnr.install
new file mode 100644
index 000000000000..6a1686251b59
--- /dev/null
+++ b/disable-llmnr.install
@@ -0,0 +1,39 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+reload_resolved() {
+ /usr/bin/systemctl reload-or-try-restart systemd-resolved
+}
+
+## arg 1: the new package version
+pre_install() {
+ :
+}
+
+## arg 1: the new package version
+post_install() {
+ reload_resolved
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+pre_upgrade() {
+ :
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ reload_resolved
+}
+
+## arg 1: the old package version
+pre_remove() {
+ :
+}
+
+## arg 1: the old package version
+post_remove() {
+ reload_resolved
+}