summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorganamilo2018-06-04 17:07:26 +0100
committermorganamilo2018-06-04 17:07:26 +0100
commitb6094598dfa474c9f4ecbe6c5e4ea33d2e07fb1e (patch)
tree4aa07828fbd57d4866f96255e946b103c30e0319
parent9b2fb86217a2630deb255b844fdb596300412a81 (diff)
downloadaur-b6094598dfa474c9f4ecbe6c5e4ea33d2e07fb1e.tar.gz
Fix desktop perms and icon
-rw-r--r--.SRCINFO4
-rw-r--r--Discord.desktop2
-rw-r--r--Discord.install1
-rw-r--r--PKGBUILD10
4 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca767286582a..2be54de0b588 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = discord
pkgdesc = All-in-one voice and text chat for gamers that's free and secure.
pkgver = 0.0.5
- pkgrel = 2
+ pkgrel = 3
url = https://discordapp.com/
install = Discord.install
arch = x86_64
@@ -20,7 +20,7 @@ pkgbase = discord
optdepends = ttf-symbola: Font for emoji support.
source = Discord.desktop
source = LICENSE
- md5sums = a9046504943624ac4861983d67a1404b
+ md5sums = 203b6c7c05e56ce3b9d9eb55d7e11d17
md5sums = 26b3229c74488c64d94798e48bc49fcd
source_x86_64 = https://dl.discordapp.net/apps/linux/0.0.5/discord-0.0.5.tar.gz
md5sums_x86_64 = 18a8e7f86d26a1472dbfff060e1671e4
diff --git a/Discord.desktop b/Discord.desktop
index 6f20612bf4aa..81afcfacc769 100644
--- a/Discord.desktop
+++ b/Discord.desktop
@@ -3,7 +3,7 @@ Name=Discord
Comment=All-in-one voice and text chat for gamers that's free, secure, and works on both your desktop and phone.
GenericName=Internet Messenger
Exec=/usr/bin/discord
-Icon=/usr/share/pixmaps/discord.png
+Icon=discord
Type=Application
StartupNotify=false
Categories=Network;InstantMessaging;
diff --git a/Discord.install b/Discord.install
index f0a992d3b34a..fc0d45716dc1 100644
--- a/Discord.install
+++ b/Discord.install
@@ -5,4 +5,5 @@ post_upgrade() {
echo ">>> If you believe there is a problem with this AUR package please report it to the AUR page"
echo ">>> If you believe there is a problem with Discord please report it to:"
echo ">>> https://discord.gg/discord-testers or https://discord.gg/discord-linux."
+ /opt/discord/postinst.sh > /dev/null
}
diff --git a/PKGBUILD b/PKGBUILD
index 521302f35bfa..fa9efe6e4108 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Cayde Dixon <me@cazzar.net>
+# Maintainer: Anna <morganamilo@gmail.com>
+# Contributor: Cayde Dixon <me@cazzar.net>
# Contributor: Anthony Anderson <aantony4122@gmail.com>
@@ -6,7 +7,7 @@ _branch='discord'
pkgname=discord
pkgver=0.0.5
-pkgrel=2
+pkgrel=3
pkgdesc="All-in-one voice and text chat for gamers that's free and secure."
arch=('x86_64')
url='https://discordapp.com/'
@@ -21,7 +22,7 @@ optdepends=(
install="Discord.install"
source=(Discord.desktop LICENSE)
source_x86_64=("https://dl.discordapp.net/apps/linux/${pkgver}/${_branch}-${pkgver}.tar.gz")
-md5sums=('a9046504943624ac4861983d67a1404b'
+md5sums=('203b6c7c05e56ce3b9d9eb55d7e11d17'
'26b3229c74488c64d94798e48bc49fcd')
md5sums_x86_64=('18a8e7f86d26a1472dbfff060e1671e4')
@@ -39,8 +40,7 @@ package() {
# Desktop Entry
- install -d "${pkgdir}/usr/share/applications"
- install "${srcdir}/Discord.desktop" "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/Discord.desktop" "${pkgdir}/usr/share/applications/Discord.desktop"
# Main binary
install -d "${pkgdir}/usr/bin"