summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpegasis2020-09-20 01:18:44 -0400
committerpegasis2020-09-20 01:18:44 -0400
commit72db0aab61a90114daa55bc1fca31a2b6f1d1fb6 (patch)
tree4884b7b38bd9f381bbb413f4313755ea41c923af
downloadaur-72db0aab61a90114daa55bc1fca31a2b6f1d1fb6.tar.gz
2.23
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
-rw-r--r--discord-chat-exporter-cli2
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0607f804d481
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = discord-chat-exporter-cli
+ pkgdesc = Export message history from a Discord channel to a file
+ pkgver = 2.23
+ pkgrel = 1
+ url = https://github.com/Tyrrrz/DiscordChatExporter
+ arch = any
+ license = GPL
+ makedepends = unzip
+ depends = dotnet-host
+ noextract = discord-chat-exporter-cli-2.23.zip
+ source = discord-chat-exporter-cli-2.23.zip::https://github.com/Tyrrrz/DiscordChatExporter/releases/download/2.23/DiscordChatExporter.CLI.zip
+ source = discord-chat-exporter-cli
+ md5sums = 6dce0b7cb0ef2065018fa66c313ae838
+ md5sums = 0fd85e697c523e950228ab4c30917d71
+
+pkgname = discord-chat-exporter-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a1cfd31628b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: JianQing Liu <admin at pegasis dot site>
+pkgname=discord-chat-exporter-cli
+pkgver=2.23
+pkgrel=1
+pkgdesc="Export message history from a Discord channel to a file"
+arch=('any')
+url="https://github.com/Tyrrrz/DiscordChatExporter"
+license=('GPL')
+depends=('dotnet-host')
+makedepends=('unzip')
+source=("$pkgname-$pkgver.zip::https://github.com/Tyrrrz/DiscordChatExporter/releases/download/$pkgver/DiscordChatExporter.CLI.zip"
+"discord-chat-exporter-cli")
+noextract=("$pkgname-$pkgver.zip")
+md5sums=('6dce0b7cb0ef2065018fa66c313ae838'
+'0fd85e697c523e950228ab4c30917d71')
+BUILDENV+=('!check')
+
+prepare() {
+ cd "$srcdir"
+ mkdir -p "$srcdir/unzip"
+ cd "$srcdir/unzip"
+ unzip -q "$srcdir/$pkgname-$pkgver.zip"
+ rm "$srcdir/$pkgname-$pkgver.zip"
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir/opt/"
+ mv "$srcdir/unzip" "$pkgdir/opt/discord-chat-exporter-cli"
+ install -m755 discord-chat-exporter-cli "$pkgdir/opt/discord-chat-exporter-cli/"
+ mkdir -p "$pkgdir/usr/bin/"
+ ln -s "/opt/discord-chat-exporter-cli/discord-chat-exporter-cli" "$pkgdir/usr/bin/discord-chat-exporter-cli"
+}
diff --git a/discord-chat-exporter-cli b/discord-chat-exporter-cli
new file mode 100644
index 000000000000..55037069277a
--- /dev/null
+++ b/discord-chat-exporter-cli
@@ -0,0 +1,2 @@
+#! /bin/sh
+/usr/bin/dotnet /opt/DiscordChatExporterCLI/DiscordChatExporter.Cli.dll "$@" \ No newline at end of file