summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSirNapkin13342021-03-16 14:16:18 -0700
committerSirNapkin13342021-03-16 14:16:18 -0700
commit01070ba24b60e9c519b96139b63f90c655dfe2b0 (patch)
tree53da4c9c6fdd8e547777954b2b11475e6a501e05
parentd40bbee664dcaaadf9016d03bed89877795d31a4 (diff)
downloadaur-01070ba24b60e9c519b96139b63f90c655dfe2b0.tar.gz
Add update script
-rwxr-xr-xupdate.sh13
1 files changed, 13 insertions, 0 deletions
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..8bee1bb294a1
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,13 @@
+#!/bin/bash
+
+# Update files
+perl -pi -e "s/pkgver=\\d+\\.\\d+\\.\\d+/pkgver=$1/" PKGBUILD
+updpkgsums
+makepkg --printsrcinfo > .SRCINFO
+
+# Push
+git add PKGBUILD .SRCINFO
+makepkg -si --noconfirm &
+git commit -m "Update to $1"
+git push
+