summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCayde Dixon2017-01-11 14:11:52 +1100
committerCayde Dixon2017-01-11 14:12:57 +1100
commitf611a341fd4369a5fa85c6063f8d14c889ea998a (patch)
tree5cde7c484f070b5b29b94582a627892ace2a62c8
downloadaur-f611a341fd4369a5fa85c6063f8d14c889ea998a.tar.gz
Discord-PTB 0.0.1
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore4
-rw-r--r--DiscordPTB.desktop10
-rw-r--r--DiscordPTB.install7
-rwxr-xr-xDiscordPTB.sh2
-rw-r--r--LICENSE1
-rw-r--r--PKGBUILD52
7 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67b18233ad9c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = discord-ptb
+ pkgdesc = Discord PTB linux release
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://discordapp.com/
+ install = DiscordPTB.install
+ arch = x86_64
+ license = custom
+ depends = gtk2
+ depends = gconf
+ depends = libnotify
+ depends = libxss
+ depends = glibc
+ depends = alsa-lib
+ depends = nspr
+ depends = nss
+ optdepends = freetype2-infinality: If you have black screens with emojis install this.
+ optdepends = libpulse: For pulseaudio support
+ provides = discord-ptb
+ source = DiscordPTB.desktop
+ source = LICENSE
+ source = DiscordPTB.sh
+ md5sums = 2ff4b71f582b9d62eadbb487d4190d15
+ md5sums = 86acf3328debd24b95cdd037a276e059
+ md5sums = f49fa4791d8feafeef470040fb16746d
+ source_x86_64 = https://dl-ptb.discordapp.net/apps/linux/0.0.1/discord-ptb-0.0.1.tar.gz
+ md5sums_x86_64 = 97c0b016d1aace174493cb18e949abd7
+
+pkgname = discord-ptb
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..470c58c1719b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.gz
+*.xz
diff --git a/DiscordPTB.desktop b/DiscordPTB.desktop
new file mode 100644
index 000000000000..3f78725c4955
--- /dev/null
+++ b/DiscordPTB.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Discord Canary
+Comment=All-in-one voice and text chat for gamers that's free, secure, and works on both your desktop and phone.
+GenericName=Internet Messenger
+Exec=/usr/bin/discord-canary
+Icon=/usr/share/pixmaps/discord-canary.png
+Type=Application
+StartupNotify=true
+Categories=Network;InstantMessaging;
+StartupWMClass=discord
diff --git a/DiscordPTB.install b/DiscordPTB.install
new file mode 100644
index 000000000000..abb819dcd4b1
--- /dev/null
+++ b/DiscordPTB.install
@@ -0,0 +1,7 @@
+post_upgrade() {
+ echo ">>> The run command changed from DiscordCanary to discord-canary"
+ echo ">>> You may need to delete discord's cache directory ~/.cache/discord"
+ echo ">>> try this if discord is stuck on the updating screen or if nothing displays but a gray box"
+ echo ">>> if this doesn't work ask for help in #linux in the Discord Developers server https://discord.gg/UT7AMAP"
+ echo ">>> You may also want to check out the linux server for help as well https://discord.gg/e7GX27C"
+}
diff --git a/DiscordPTB.sh b/DiscordPTB.sh
new file mode 100755
index 000000000000..530030076e62
--- /dev/null
+++ b/DiscordPTB.sh
@@ -0,0 +1,2 @@
+#!/bin/bash
+PULSE_LATENCY_MSEC=30 /opt/discord-ptb/DiscordPTB
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..afdc5112be2a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1 @@
+Copyright (c) 2016 Hammer & Chisel
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad3da2dff218
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Cayde Dixon <me@cazzar.net>
+# Contributor: Anthony Anderson <aantony4122@gmail.com>
+
+pkgname=discord-ptb
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='Discord PTB linux release'
+arch=('x86_64')
+url='https://discordapp.com/'
+provides=('discord-ptb')
+license=('custom')
+depends=('gtk2' 'gconf' 'libnotify' 'libxss' 'glibc' 'alsa-lib' 'nspr' 'nss')
+optdepends=('freetype2-infinality: If you have black screens with emojis install this.' 'libpulse: For pulseaudio support' )
+
+install="DiscordPTB.install"
+source=(DiscordPTB.desktop LICENSE DiscordPTB.sh)
+source_x86_64=("https://dl-ptb.discordapp.net/apps/linux/${pkgver}/discord-ptb-${pkgver}.tar.gz")
+
+
+
+#This is always latest build, right now I do not know of a version param.
+
+package() {
+ # Install the main files.
+ install -d "${pkgdir}/opt/${pkgname}"
+ cp -a "${srcdir}/DiscordPTB/." "${pkgdir}/opt/${pkgname}"
+
+ # Exec bit
+ chmod 755 "${pkgdir}/opt/${pkgname}/DiscordPTB"
+
+
+ # Desktop Entry
+ install -d "${pkgdir}/usr/share/applications"
+ install "${srcdir}/DiscordPTB.desktop" "${pkgdir}/usr/share/applications"
+
+ # Main binary
+ install -d "${pkgdir}/usr/bin"
+ #ln -s "/opt/${pkgname}/DiscordCanary" "${pkgdir}/usr/bin/DiscordCanary"
+ #installing from .sh due to how the tar extracts.
+ install "${srcdir}/DiscordPTB.sh" "${pkgdir}/usr/bin/discord-ptb"
+
+ # Create symbolic link to the icon
+ install -d "${pkgdir}/usr/share/pixmaps"
+ ln -s "/opt/${pkgname}/discord.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+
+ # License
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+md5sums=('2ff4b71f582b9d62eadbb487d4190d15'
+ '86acf3328debd24b95cdd037a276e059'
+ 'f49fa4791d8feafeef470040fb16746d')
+md5sums_x86_64=('97c0b016d1aace174493cb18e949abd7')