summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalte Jürgens2022-07-18 17:29:15 +0000
committerMalte Jürgens2022-07-18 17:30:31 +0000
commit2530688a6fa354146d0a457e73a4773f027da282 (patch)
tree353445c7fff8fe6a9897d456ca954712e42e9648
downloadaur-2530688a6fa354146d0a457e73a4773f027da282.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09b722bc672c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = discord-screenaudio
+ pkgdesc = Custom discord client with the ability to stream desktop audio
+ pkgver = 1.0.0.rc.2
+ pkgrel = 1
+ url = https://github.com/maltejur/discord-screenaudio
+ arch = x86_64
+ license = GPL-3.0
+ makedepends = cmake
+ makedepends = qt5-base
+ makedepends = qt5-webengine
+ makedepends = pipewire
+ depends = pipewire
+ source = discord-screenaudio-1.0.0.rc.2.tar.gz::https://github.com/maltejur/discord-screenaudio/archive/refs/tags/v1.0.0-rc.2.tar.gz
+ sha256sums = b999c9d3f99f9e5b0c30b1ae18e6620e8b6e380eaaadc5db144eeab33d0d6078
+
+pkgname = discord-screenaudio
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db5897238ae3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Malte Jürgens <maltejur@dismail.de>
+
+pkgname=discord-screenaudio
+pkgver=1.0.0.rc.2
+pkgrel=1
+pkgdesc="Custom discord client with the ability to stream desktop audio"
+arch=("x86_64")
+url="https://github.com/maltejur/discord-screenaudio"
+license=("GPL-3.0")
+depends=(pipewire)
+makedepends=(cmake qt5-base qt5-webengine pipewire)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/maltejur/$pkgname/archive/refs/tags/v1.0.0-rc.2.tar.gz")
+sha256sums=("b999c9d3f99f9e5b0c30b1ae18e6620e8b6e380eaaadc5db144eeab33d0d6078")
+
+build() {
+ cmake -B build -S $pkgname-1.0.0-rc.2 -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build --config Release
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}