summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn C. Allwein2020-10-22 10:01:20 -0400
committerJohn C. Allwein2020-10-22 10:01:20 -0400
commit9cbb7d1fd787bae2a89f23f94c5dbf7def7a2733 (patch)
tree14829d8910be339682a1af138c7a241db9d889fe
parent066975f968fd8f872410e95b1c9abaa3e07ef12b (diff)
downloadaur-9cbb7d1fd787bae2a89f23f94c5dbf7def7a2733.tar.gz
wrapper: use exec to avoid keeping shell process around, thanks codicodi for pointing it out
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b436f7469c02..a821e3f78981 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = discord_arch_electron
pkgdesc = Discord (popular voice + video app) using the system provided electron for increased security and performance
pkgver = 0.0.12
- pkgrel = 2
+ pkgrel = 3
url = https://discordapp.com
arch = x86_64
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index 3036ad0f7ccb..37acaf99203d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=discord_arch_electron
_pkgname=discord
pkgver=0.0.12
-pkgrel=2
+pkgrel=3
pkgdesc="Discord (popular voice + video app) using the system provided electron for increased security and performance"
arch=('x86_64')
provides=('discord')
@@ -39,7 +39,7 @@ package() {
# Create starter script for discord
echo "#!/bin/sh" >> "$pkgdir"/opt/$_pkgname/$_pkgname
- echo "electron /opt/$_pkgname/resources/app.asar \$@" >> "$pkgdir"/opt/$_pkgname/$_pkgname
+ echo "exec electron /opt/$_pkgname/resources/app.asar \$@" >> "$pkgdir"/opt/$_pkgname/$_pkgname
# Set Permissions, symlinks
chmod 755 "$pkgdir"/opt/$_pkgname/$_pkgname