summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2016-12-19 13:08:58 +0100
committerNicolas Iooss2016-12-19 13:08:58 +0100
commit1c495b7cc5301901f05c134879848497bd8c4e69 (patch)
treecc095e684e2fd9c8758c2c5c1220b2d474eb077f
downloadaur-1c495b7cc5301901f05c134879848497bd8c4e69.tar.gz
Initial release
-rw-r--r--.SRCINFO17
-rw-r--r--Discovery+200.curaprofile36
-rw-r--r--PKGBUILD32
-rw-r--r--discovery_200.json36
-rw-r--r--sdcard__auto0.g8
-rw-r--r--sdcard__move_cura_gcode.sh13
6 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f377614eba4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = discovery200-files
+ pkgdesc = Files to use a Discovery 200 3D Printer
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.dagoma.fr/en/produit/imprimante-discovery200/
+ arch = any
+ license = GPL
+ optdepends = arduino: for Arduino programming
+ optdepends = cura: for crafting gcode files from 3D models
+ optdepends = printrun: to drive the printer through USB with pronterface
+ source = https://github.com/Lauszus/Sanguino/releases/download/1.0.0/Sanguino.zip
+ source = discovery_200.json
+ sha256sums = 1bfe7707894907a2792884fc726e1fe9251842fac75eaf5ef451bba0c18cbb4e
+ sha256sums = af36f64f8ec3832cf996a315d16f3a3f0a269ee233a1a3e5c76ada03135aeace
+
+pkgname = discovery200-files
+
diff --git a/Discovery+200.curaprofile b/Discovery+200.curaprofile
new file mode 100644
index 000000000000..7f33aea3cee2
--- /dev/null
+++ b/Discovery+200.curaprofile
@@ -0,0 +1,36 @@
+; This file lies in ~/.local/share/cura/instance_profiles/Discovery+200.curaprofile
+[general]
+version = 1
+name = Current settings
+weight = 0
+type = machine_instance_profile
+
+[settings]
+support_roof_enable = True
+retraction_amount = 3.5
+support_type = everywhere
+support_enable = True
+adhesion_type = brim
+cool_min_layer_time = 3
+material_print_temperature = 200
+material_flow = 100
+layer_height = 0.2
+support_roof_density = 80
+retraction_speed = 50
+infill_sparse_density = 20
+wall_thickness = 1
+cool_fan_full_layer = 1
+
+[defaults]
+infill_sparse_density = 10
+speed_topbottom = 30
+layer_height = 0.15
+speed_wall_0 = 40
+wall_thickness = 1
+cool_min_layer_time = 3
+speed_wall_x = 80
+speed_infill = 100
+
+[disabled_defaults]
+values = speed_wall_0,speed_wall_x,speed_topbottom,speed_infill,
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9aebf85343b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
+pkgname=discovery200-files
+pkgver=1.0
+pkgrel=1
+pkgdesc="Files to use a Discovery 200 3D Printer"
+arch=(any)
+url="http://www.dagoma.fr/en/produit/imprimante-discovery200/"
+license=('GPL')
+optdepends=(
+ 'arduino: for Arduino programming'
+ 'cura: for crafting gcode files from 3D models'
+ 'printrun: to drive the printer through USB with pronterface')
+source=('https://github.com/Lauszus/Sanguino/releases/download/1.0.0/Sanguino.zip'
+ 'discovery_200.json')
+sha256sums=('1bfe7707894907a2792884fc726e1fe9251842fac75eaf5ef451bba0c18cbb4e'
+ 'af36f64f8ec3832cf996a315d16f3a3f0a269ee233a1a3e5c76ada03135aeace')
+
+prepare() {
+ # Lower the upload speed for the printer board
+ sed -i 's/^\(sanguino\.menu\.cpu\.atmega1284p\.upload.speed\)=115200/\1=57600/' "$srcdir/Sanguino/boards.txt"
+}
+
+package() {
+ # Install Sanguino profile for Arduino, as the printer uses Sanguino with ATmega1284P 16MHz
+ # c.f. https://github.com/Lauszus/Sanguino/
+ mkdir -p "$pkgdir/usr/share/arduino/hardware/sanguino/avr"
+ cp -R "$srcdir/Sanguino/"* "$pkgdir/usr/share/arduino/hardware/sanguino/avr/"
+
+ # Install a Cura printer
+ # FIXME: this JSON file uses the Prusa platform, which is not Dagoma's one
+ install -m644 -D "$srcdir/discovery_200.json" "$pkgdir/usr/share/cura/resources/machines/discovery_200.json"
+}
diff --git a/discovery_200.json b/discovery_200.json
new file mode 100644
index 000000000000..3f2629d1acf3
--- /dev/null
+++ b/discovery_200.json
@@ -0,0 +1,36 @@
+{
+ "id": "discovery_200",
+ "version": 1,
+ "name": "Discovery 200",
+ "manufacturer": "Dagoma",
+ "author": "Other",
+ "icon": "icon_ultimaker2.png",
+ "platform": "prusai3_platform.stl",
+ "file_formats": "text/x-gcode",
+ "inherits": "fdmprinter.json",
+
+ "machine_settings": {
+ "machine_heated_bed": { "default": false },
+ "machine_width": { "default": 203 },
+ "machine_height": { "default": 211 },
+ "machine_depth": { "default": 211 },
+ "machine_center_is_zero": { "default": false },
+ "machine_nozzle_size": { "default": 0.4 },
+ "material_diameter": { "default": 1.75 },
+ "machine_nozzle_heat_up_speed": { "default": 2.0 },
+ "machine_nozzle_cool_down_speed": { "default": 2.0 },
+ "machine_head_shape_min_x": { "default": 75 },
+ "machine_head_shape_min_y": { "default": 18 },
+ "machine_head_shape_max_x": { "default": 18 },
+ "machine_head_shape_max_y": { "default": 35 },
+ "machine_nozzle_gantry_distance": { "default": 55 },
+ "machine_gcode_flavor": { "default": "RepRap (Marlin/Sprinter)" },
+
+ "machine_start_gcode": {
+ "default": "G21 ;metric values\nG90 ;absolute positioning\nM82 ;set extruder to absolute mode\nM106 S130 ;start with the fan ON!\nG28 ;move X/Y/Z to min endstops\nG29 ;auto bed leveling\nG1 Z15.0 F9000 ;move the platform down 15mm\nG92 E0 ;zero the extruded length\nG1 F200 E3 ;extrude 3mm of feed stock\nG92 E0 ;zero the extruded length again\nG1 F9000\n;Put printing message on LCD screen\nM117 Printing..."
+ },
+ "machine_end_gcode": {
+ "default": "M106 S130 ;set the fan to medium speed\nM104 S0 ;extruder heater off\nM140 S0 ;heated bed heater off (if you have it)\nG91 ;relative positioning\nG1 E-1 F300 ;retract the filament a bit before lifting the nozzle, to release some of the pressure\nG1 Z+0.5 E-5 X-20 Y-20 F9000 ;move Z up a bit and retract filament even more\nG28 X0 Y0 ;move X/Y to min endstops, so the head is out of the way\nM84 ;steppers off\nG90 ;absolute positioning"
+ }
+ }
+}
diff --git a/sdcard__auto0.g b/sdcard__auto0.g
new file mode 100644
index 000000000000..3a15a150c9a0
--- /dev/null
+++ b/sdcard__auto0.g
@@ -0,0 +1,8 @@
+;FLAVOR:RepRap
+M106 S130 ;turn the fan on
+;M851 Z-1.1
+M851 Z-0.9
+M500
+G28 Z ; Home Z
+M23 dagoma.g
+M24 ;print file
diff --git a/sdcard__move_cura_gcode.sh b/sdcard__move_cura_gcode.sh
new file mode 100644
index 000000000000..071ea6730c72
--- /dev/null
+++ b/sdcard__move_cura_gcode.sh
@@ -0,0 +1,13 @@
+#!/bin/sh
+cd "$(dirname -- "$0")" || exit $?
+
+FILES="$(find . -maxdepth 1 -name 'D200_*.gcode')"
+if [ "$(echo "$FILES" |wc -w)" -ne 1 ]
+then
+ echo >&2 "Error: not a single D200 GCode file"
+ exit 1
+fi
+
+# Never stop the fan
+sed 's/^M107$/M106 S130/' "$FILES" > dagoma.g
+echo 'dagoma.g is ready!'