summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjdn062015-10-27 01:37:44 +0100
committerjdn062015-10-27 01:37:44 +0100
commitfa5c00e9fa4a889dae4e61b47f95e20e06ad67c6 (patch)
tree4a0d8198b15af1146280b436650f4270163358fa
downloadaur-fa5c00e9fa4a889dae4e61b47f95e20e06ad67c6.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
-rw-r--r--patch-ninja9
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0d78515ec73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = diskscan
+ pkgdesc = CLI tool to scan block devices for unreadable sectors
+ pkgver = 0.17
+ pkgrel = 1
+ url = https://github.com/baruch/diskscan
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = ninja
+ makedepends = ctags
+ depends = python-yaml
+ source = https://codeload.github.com/baruch/diskscan/tar.gz/0.17
+ source = patch-ninja
+ sha256sums = 92f99352d70dbfb7a806e5d706821a4b3ec2841b0ac7997c072a896e2da3a595
+ sha256sums = 2e92c4517e154d22319195f2486b4d6bfef856215ce8778dd698daa175fa9117
+
+pkgname = diskscan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61ce7fef3aa3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: jdn06 <jdn06.jdn06@outlook.fr>
+
+pkgname=diskscan
+pkgver=0.17
+pkgrel=1
+pkgdesc="CLI tool to scan block devices for unreadable sectors"
+arch=('i686' 'x86_64')
+url="https://github.com/baruch/diskscan"
+license=('GPL3')
+depends=('python-yaml')
+makedepends=('ninja' 'ctags')
+install=
+source=("https://codeload.github.com/baruch/$pkgname/tar.gz/$pkgver"
+ "patch-ninja")
+sha256sums=('92f99352d70dbfb7a806e5d706821a4b3ec2841b0ac7997c072a896e2da3a595' '2e92c4517e154d22319195f2486b4d6bfef856215ce8778dd698daa175fa9117')
+#sha256sums=(SKIP SKIP)
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure
+ #To fix build with ninja 1.6
+ patch build.ninja ../patch-ninja
+
+ #To fix a problem with python 3
+ sed -i 's/file(filename)/open(filename)/' libscsicmd/structs/ata_struct_2_h.py
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ninja
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/man/man1"
+
+ make DESTDIR="$pkgdir/" PREFIX="/usr" install
+}
diff --git a/patch-ninja b/patch-ninja
new file mode 100644
index 000000000000..95ae67c0310d
--- /dev/null
+++ b/patch-ninja
@@ -0,0 +1,9 @@
+14c14
+< ldflags = -ltermcap -lm -lz -Wl,-O1,--sort-common,--as-needed,-z,relro
+---
+> ldflags = -lncurses -lm -lz -Wl,-O1,--sort-common,--as-needed,-z,relro
+93a94,97
+>
+> rule script
+> command = $script $in > $out
+> description = SCRIPT $script $in