summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-08-19 14:25:32 +0200
committerKrzysztof (3ED) AS2015-08-19 14:25:32 +0200
commitb35895e4efe22682f9d41260bca17b052fbcaca0 (patch)
tree7bc3008f86d9a5f3ebae6198ddf957557e2c1f1a
downloadaur-b35895e4efe22682f9d41260bca17b052fbcaca0.tar.gz
Initial
-rw-r--r--.SRCINFO18
-rw-r--r--10-Makefile_small_tweakfix.patch20
-rw-r--r--11-disksearch_bin_script_paths_fix.patch10
-rw-r--r--PKGBUILD32
4 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e13aa6f11b4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = disksearch
+ pkgdesc = is a tool for searching for files on removable media disks (e.g. for songs on your MP3-CD's)
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = http://www.saring.de/disksearch/
+ arch = any
+ license = GPL
+ depends = python2
+ depends = pygtk
+ source = http://downloads.sourceforge.net/disksearch/disksearch-1.2.1.tar.gz
+ source = 10-Makefile_small_tweakfix.patch
+ source = 11-disksearch_bin_script_paths_fix.patch
+ sha256sums = 58711b617382582ad59d9d3ccf95d9a6eb9b620237455b4e586a6efa387258d7
+ sha256sums = 3d698b3eb7c18af4f9f045fb23246569608bcab8d2567c87629f693120a9e71b
+ sha256sums = c611e37f5804f35cc26f2a14ec34fe630c0e26d6735e649ac57e54bb45fb76cb
+
+pkgname = disksearch
+
diff --git a/10-Makefile_small_tweakfix.patch b/10-Makefile_small_tweakfix.patch
new file mode 100644
index 000000000000..edb4e6f9784c
--- /dev/null
+++ b/10-Makefile_small_tweakfix.patch
@@ -0,0 +1,20 @@
+--- Makefile.orig 2015-08-19 12:02:25.595782072 +0000
++++ Makefile 2015-08-19 12:08:24.987308899 +0000
+@@ -2,7 +2,7 @@
+ # Stefan Saring & Mathias Obst, 2007/03/05
+
+ # specify the directory for installation
+-prefix = /usr/local
++prefix = $(DESTDIR)/usr
+
+ bindir = $(prefix)/bin
+ datadir = $(prefix)/share
+@@ -26,6 +26,8 @@
+ REMOVE_DIR = $(REMOVE) -r -f
+
+
++default: gmo
++
+ # Install DiskSearch
+ install: uninstall_disksearch uninstall_cdsearch install_disksearch
+
diff --git a/11-disksearch_bin_script_paths_fix.patch b/11-disksearch_bin_script_paths_fix.patch
new file mode 100644
index 000000000000..516f3428ce38
--- /dev/null
+++ b/11-disksearch_bin_script_paths_fix.patch
@@ -0,0 +1,10 @@
+--- disksearch.orig 2015-08-19 12:14:53.385456312 +0000
++++ disksearch 2015-08-19 12:15:38.765622651 +0000
+@@ -3,5 +3,5 @@
+ # to modify the name of the Python executable (e.g. "python2.2").
+ # Stefan Saring & Mathias Obst, 2004/11/04
+
+-cd /usr/local/share/disksearch
+-python disksearch.py $*
++cd /usr/share/disksearch
++python2 disksearch.py "$@"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67f7e733f4a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: 3ED_0 <krzysztof1987 @ gmail.com>
+
+pkgname=disksearch
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="is a tool for searching for files on removable media disks (e.g. for songs on your MP3-CD's)"
+arch=('any')
+url="http://www.saring.de/disksearch/"
+license=('GPL')
+depends=('python2' 'pygtk')
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+ "10-Makefile_small_tweakfix.patch"
+ "11-disksearch_bin_script_paths_fix.patch")
+noextract=()
+sha256sums=('58711b617382582ad59d9d3ccf95d9a6eb9b620237455b4e586a6efa387258d7'
+ '3d698b3eb7c18af4f9f045fb23246569608bcab8d2567c87629f693120a9e71b'
+ 'c611e37f5804f35cc26f2a14ec34fe630c0e26d6735e649ac57e54bb45fb76cb')
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Np0 -i "$srcdir/10-Makefile_small_tweakfix.patch"
+ patch -Np0 -i "$srcdir/11-disksearch_bin_script_paths_fix.patch"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}