summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormrxx2015-07-07 13:51:00 +0200
committerLukas Fleischer2015-07-08 13:24:31 +0200
commit73d4c74bda96acf31bbacb341eda00aa7a22436b (patch)
tree0370c67bbd3565a175c7bed860f3dcdb06f8c43e
downloadaur-73d4c74bda96acf31bbacb341eda00aa7a22436b.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b835c06e896
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dislocker
+ pkgdesc = Read BitLocker encrypted volumes under Linux
+ pkgver = 0.4
+ pkgrel = 1
+ url = http://www.hsc.fr/ressources/outils/dislocker
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = fuse
+ depends = polarssl
+ optdepends = ntfs-3g: NTFS file system support
+ conflicts = dislocker-git
+ source = https://github.com/Aorimn/dislocker/archive/v0.4.tar.gz
+ md5sums = 440d4a107d3f4fa56cb8e4ca7b62e645
+
+pkgname = dislocker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8587c228ff67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: mrxx <mrxx at cyberhome dot at>
+
+pkgname=dislocker
+pkgver=0.4
+pkgrel=1
+pkgdesc="Read BitLocker encrypted volumes under Linux"
+arch=('i686' 'x86_64')
+url="http://www.hsc.fr/ressources/outils/dislocker"
+license=('GPL2')
+depends=('fuse' 'polarssl')
+conflicts=('dislocker-git')
+optdepends=('ntfs-3g: NTFS file system support')
+source=(https://github.com/Aorimn/dislocker/archive/v$pkgver.tar.gz)
+md5sums=('440d4a107d3f4fa56cb8e4ca7b62e645')
+
+build() {
+ cd "$pkgname-$pkgver/src"
+ make all
+}
+
+package() {
+ cd "$pkgname-$pkgver/src"
+ mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/lib" "$pkgdir/usr/share/man/man1"
+ make DESTDIR="$pkgdir/usr" install
+}