summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2024-03-30 19:33:25 +0000
committerJoão Figueiredo2024-03-30 19:33:25 +0000
commita39f7926e0be934ebb10df1343bb81c1e0b5fe64 (patch)
treec71c7824105e1c06610f0af7404cdcbcb13d892a
parent500ab5953204a604e06ed7343bcf26d2491f4430 (diff)
downloadaur-a39f7926e0be934ebb10df1343bb81c1e0b5fe64.tar.gz
Update source
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31d02142008a..9227537c4d81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = disman-git
pkgdesc = Qt/C++ display management library by the KWinFT project (libkscreen fork)
- pkgver = 0.527.80_r1871.geb61ea1
+ pkgver = 0.600.0_r1876.ge213fd1
pkgrel = 1
- url = https://gitlab.com/kwinft/disman
+ url = https://github.com/winft/disman
arch = x86_64
license = LGPL
makedepends = git
@@ -17,7 +17,7 @@ pkgbase = disman-git
optdepends = kwayland-git: for the KDE output-management backend plugin
provides = disman
conflicts = disman
- source = git+https://gitlab.com/kwinft/disman.git
+ source = git+https://github.com/winft/disman.git
sha512sums = SKIP
pkgname = disman-git
diff --git a/PKGBUILD b/PKGBUILD
index 8c2012041ac9..47040bd36766 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# Author: Matthias Blaicher <matthias at blaicher dot com>
pkgname=disman-git
-pkgver=0.527.80_r1871.geb61ea1
+pkgver=0.600.0_r1876.ge213fd1
pkgrel=1
pkgdesc='Qt/C++ display management library by the KWinFT project (libkscreen fork)'
arch=($CARCH)
-url='https://gitlab.com/kwinft/disman'
+url='https://github.com/winft/disman'
license=(LGPL)
depends=(kcoreaddons-git qt6-base)
makedepends=(git extra-cmake-modules-git kwayland-git libxcb wrapland-git)
@@ -16,12 +16,12 @@ optdepends=('libxcb: for the X11 backend plugin'
'kwayland-git: for the KDE output-management backend plugin')
provides=(${pkgname%-git})
conflicts=(${pkgname%-git})
-source=("git+https://gitlab.com/kwinft/disman.git")
+source=("git+$url.git")
sha512sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- _ver="$(grep -m1 'set(PROJECT_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ _ver="$(grep -im1 "project(${pkgname%-git} VERSION" CMakeLists.txt | sed 's/.* //; s/-/./g; s/)//')"
echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}