summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-02-02 02:06:51 +0000
committerJoão Figueiredo2021-02-02 02:06:51 +0000
commitbc1b746e18248355487651b13c58c4a02f35884e (patch)
treee216f0cb6ce720814c1cd35abb906e48edd60e42
parente49d7a7a17c9e90cbbdc16ab26d466564da36b97 (diff)
downloadaur-bc1b746e18248355487651b13c58c4a02f35884e.tar.gz
Updated deps and building
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD56
2 files changed, 25 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f81afb912538..381c134310ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = disman-git
pkgdesc = Qt/C++ display management library by KWinFT project ~ forked from KDE libkscreen
- pkgver = 0.520.0.beta.0.r28.ga3971e7
+ pkgver = 0.520.80_r1786.g86c46bb
pkgrel = 1
url = https://gitlab.com/kwinft/disman
- arch = i686
arch = x86_64
+ groups = plasma-git
license = LGPL
- makedepends = extra-cmake-modules
makedepends = git
- makedepends = kcoreaddons
- makedepends = ninja
- depends = kwayland
- depends = libxrandr
+ makedepends = extra-cmake-modules-git
+ makedepends = kwayland
+ makedepends = libxcb
+ makedepends = wrapland-git
+ depends = kcoreaddons-git
depends = qt5-x11extras
- depends = wrapland
+ optdepends = libxcb: for the X11 backend plugin
+ optdepends = wrapland-git: for the KWinFT and wlroots backend plugins
+ optdepends = kwayland-git: for the KDE output-management backend plugin
provides = disman
conflicts = disman
source = git+https://gitlab.com/kwinft/disman.git
diff --git a/PKGBUILD b/PKGBUILD
index e083b90d4028..94fac01d918a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,35 @@
-# Maintainer: Christoph Haag <christoph.haag@collabora.com>
+# Maintainer: João Figueiredo <jf.mundox@gmail.com>
+# Contributor: Christoph Haag <christoph.haag@collabora.com>
# Author: Matthias Blaicher <matthias at blaicher dot com>
pkgname=disman-git
-pkgver=0.520.0.beta.0.r28.ga3971e7
+pkgver=0.520.80_r1786.g86c46bb
pkgrel=1
pkgdesc='Qt/C++ display management library by KWinFT project ~ forked from KDE libkscreen'
-arch=(
- i686
- x86_64
-)
+arch=($CARCH)
url='https://gitlab.com/kwinft/disman'
license=(LGPL)
-depends=(
- kwayland
- libxrandr
- qt5-x11extras
- wrapland
-)
-makedepends=(
- extra-cmake-modules
- git
- kcoreaddons
- ninja
-)
+groups=(plasma-git)
+depends=(kcoreaddons-git qt5-x11extras)
+makedepends=(git extra-cmake-modules-git kwayland libxcb wrapland-git)
+optdepends=('libxcb: for the X11 backend plugin' 'wrapland-git: for the KWinFT and wlroots backend plugins' 'kwayland-git: for the KDE output-management backend plugin')
provides=(disman)
conflicts=(disman)
source=('git+https://gitlab.com/kwinft/disman.git')
sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/disman"
-
- git describe --long --tags | sed "s/^disman\@//;s/\([^-]*-g\)/r\1/;s/-/./g"
-}
-
-prepare() {
- mkdir -p "$srcdir/build"
+ cd ${pkgname%-git}
+ _ver="$(grep -m1 'set(PROJECT_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/build"
-
- cmake \
- "$srcdir/disman" \
- -G Ninja \
- -D CMAKE_BUILD_TYPE="Release" \
- -D CMAKE_INSTALL_PREFIX="/usr" \
- -D KDE_INSTALL_LIBDIR="lib" \
- -D KDE_INSTALL_LIBEXECDIR="lib" \
- -D KDE_INSTALL_USE_QT_SYS_PATHS="ON" \
- -D BUILD_TESTING="OFF"
-
- ninja
+ cmake -B build -S ${pkgname%-git} \
+ -DBUILD_TESTING=OFF
+ cmake --build build
}
package() {
- cd "$srcdir/build"
-
- DESTDIR="$pkgdir" ninja install
+ DESTDIR="$pkgdir" cmake --install build
}