summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorabelian4242023-11-11 10:51:39 +0600
committerabelian4242023-11-11 10:51:39 +0600
commit9b0660038e76a01bb5eb4ebffe3dd81502c95630 (patch)
tree1f0c501e30af9f1ade2fa9dbb1db066fb24ca7a5
parentb988daffdcc24a36813a4e44ff70ea01cb54b5ef (diff)
downloadaur-9b0660038e76a01bb5eb4ebffe3dd81502c95630.tar.gz
Reverted recent changes that obfuscated the fact that this is the release package which is equivalent to tag disman@0.527.0 and branch Plasma/5.27 on the GitLab repo. Thanks to xiota for his help and criticism.Also, pkgver() was changed to make it easier to compare to disman-git
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e346f90247d6..dabda99591e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = disman-kwinft
pkgdesc = Qt/C++ display management library
- pkgver = 5.27
- pkgrel = 3
+ pkgver = 0.527.0
+ pkgrel = 1
url = https://gitlab.com/kwinft/disman
arch = x86_64
arch = aarch64
@@ -9,13 +9,14 @@ pkgbase = disman-kwinft
makedepends = extra-cmake-modules
makedepends = git
makedepends = kdoctools5
+ makedepends = qt5-tools
+ makedepends = appstream
depends = kcoreaddons5
depends = qt5-x11extras
depends = wrapland
- optdepends = qt6-tools
provides = disman
conflicts = disman
- source = git+https://gitlab.com/kwinft/disman.git
- sha256sums = SKIP
+ source = https://gitlab.com/kwinft/disman/-/archive/disman@0.527.0/disman-disman@0.527.0.tar.gz
+ sha1sums = 02ab18a807a87124ecb8451db5359f3ec7bfbea6
pkgname = disman-kwinft
diff --git a/PKGBUILD b/PKGBUILD
index b8664625c921..43feb41b6d71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Author: Roman Gilg <subdiff@gmail.com>
pkgname=disman-kwinft
-pkgver=5.27
-pkgrel=3
+pkgver=0.527.0
+pkgrel=1
pkgdesc='Qt/C++ display management library'
arch=(x86_64 aarch64)
url="https://gitlab.com/kwinft/disman"
@@ -10,26 +10,20 @@ license=(LGPL)
depends=(kcoreaddons5 qt5-x11extras wrapland)
provides=("disman")
conflicts=("disman")
-makedepends=(extra-cmake-modules git kdoctools5)
-optdepends=(qt6-tools)
-source=("git+https://gitlab.com/kwinft/disman.git")
-sha256sums=('SKIP')
+makedepends=(extra-cmake-modules git kdoctools5 qt5-tools appstream)
+source=("https://gitlab.com/kwinft/disman/-/archive/disman@$pkgver/disman-disman@$pkgver.tar.gz")
+sha1sums=('02ab18a807a87124ecb8451db5359f3ec7bfbea6')
prepare() {
- cd disman
- git checkout Plasma/$pkgver
+ mkdir -p $pkgname
+ cd $pkgname
+ tar -xvf ../disman-disman@$pkgver.tar.gz --strip-components 1
}
build() {
mkdir -p build
cd build
- cmake ../disman \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_INSTALL_LIBEXECDIR=lib \
- -DBUILD_TESTING=OFF
- make
+ cmake ../$pkgname
}
package() {