summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2022-03-20 01:18:30 +0800
committerjustforlxz2022-03-20 01:18:30 +0800
commit0b994e64b7b98cb2e25d938d5803fd4ece3fbc3e (patch)
tree6d7f6b1dd38ab8b67ab7267e68d7c2f14a91288a
parent7af7a1ba1f058e0af15c592f48fd8ff6205c0877 (diff)
downloadaur-0b994e64b7b98cb2e25d938d5803fd4ece3fbc3e.tar.gz
update
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bfed281a7d1b..6136049db50b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,6 +4,7 @@ pkgbase = disomaster-git
pkgrel = 1
url = https://github.com/linuxdeepin/disomaster
arch = x86_64
+ arch = aarch64
groups = deepin-git
license = GPL3
makedepends = git
@@ -11,7 +12,7 @@ pkgbase = disomaster-git
depends = libisoburn
provides = disomaster
conflicts = disomaster
- source = disomaster-git::git://github.com/linuxdeepin/disomaster
+ source = disomaster-git::git+https://github.com/linuxdeepin/disomaster
sha512sums = SKIP
pkgname = disomaster-git
diff --git a/PKGBUILD b/PKGBUILD
index d08227406c87..ca83da2bbb49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=disomaster-git
pkgver=5.0.7.r2.g157dd8f
pkgrel=1
pkgdesc='Library to manipulate DISC burning.'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://github.com/linuxdeepin/disomaster"
license=('GPL3')
depends=('libisoburn')
@@ -12,7 +12,7 @@ makedepends=('git' 'qt5-tools')
groups=('deepin-git')
provides=('disomaster')
conflicts=('disomaster')
-source=("$pkgname::git://github.com/linuxdeepin/disomaster")
+source=("$pkgname::git+https://github.com/linuxdeepin/disomaster")
sha512sums=('SKIP')
pkgver() {
@@ -20,6 +20,13 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd $pkgname
+ if [[ ! -z ${sha} ]];then
+ git checkout -b $sha
+ fi
+}
+
build() {
cd ${pkgname}
qmake-qt5 PREFIX=/usr