summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLamelos2018-11-07 09:05:30 +0100
committerThomas Rijpstra2018-11-07 09:28:06 +0100
commit2b7821950313878a0ac9f3373fba4a5974ff23ca (patch)
tree4d61bd1a12735558ef08d163906efe996f8bc822
downloadaur-2b7821950313878a0ac9f3373fba4a5974ff23ca.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
-rw-r--r--dispad.conf.example44
-rw-r--r--dispad.install15
-rw-r--r--dispad.service9
5 files changed, 129 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7de9b8b66cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = dispad-git
+ pkgdesc = A small (user) daemon for disabling trackpads on keyboard input for XOrg.
+ pkgver = r53.5b7528c
+ pkgrel = 1
+ url = https://github.com/BlueDragonX/dispad
+ install = dispad.install
+ arch = any
+ license = GPLv2
+ makedepends = automake
+ makedepends = git
+ depends = confuse
+ depends = libxi
+ depends = xorg-server
+ source = dispad-git::git://github.com/BlueDragonX/dispad.git
+ source = dispad.service
+ source = dispad.conf.example
+ sha256sums = SKIP
+ sha256sums = 85ab4a6596aa520663c8a28920f8d7a03455b2f5c3f4831b755440e0de13336f
+ sha256sums = 8c707e39a5a298a08babad2da4819dfa37d9895ef0131426e81f3608cfa77a88
+
+pkgname = dispad-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..599e04eea983
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Lamelos <lamelos plus aur at gmail dot com>
+
+_pkgname=dispad
+pkgname=$_pkgname-git
+pkgver=r53.5b7528c
+pkgrel=1
+pkgdesc='A small (user) daemon for disabling trackpads on keyboard input for XOrg.'
+license=('GPLv2')
+url='https://github.com/BlueDragonX/dispad'
+arch=('any')
+depends=('confuse' 'libxi' 'xorg-server')
+makedepends=('automake' 'git')
+install=$_pkgname.install
+source=("$pkgname"::"git://github.com/BlueDragonX/dispad.git"
+ "$_pkgname.service"
+ "$_pkgname.conf.example")
+sha256sums=('SKIP'
+ '85ab4a6596aa520663c8a28920f8d7a03455b2f5c3f4831b755440e0de13336f'
+ '8c707e39a5a298a08babad2da4819dfa37d9895ef0131426e81f3608cfa77a88')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./configure --prefix="/usr"
+ make -j$(nproc)
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 "../$_pkgname.service" "$pkgdir/usr/lib/systemd/user/$_pkgname.service"
+ install -Dm644 "../$_pkgname.conf.example" "$pkgdir/etc/dispad/$_pkgname.conf.example"
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/dispad.conf.example b/dispad.conf.example
new file mode 100644
index 000000000000..6c46bcd6d372
--- /dev/null
+++ b/dispad.conf.example
@@ -0,0 +1,44 @@
+# property
+#
+# The name of the XInput property which is used to disable/enable the
+# trackpad(s). dispad will modify this property on all trackpad devices which
+# contain it. String value. Defaults to "Trackpad Disable Input".
+#property="Trackpad Disable Input".
+
+# enable
+#
+# The specified XInput property is set to this value when enabling trackpad
+# input. Unsigned 8-bit integer value. Defaults to 0.
+#enable=0
+
+# disable
+#
+# The specified XInput property is set to this value when disabling trackpad
+# input. Unsigned 8-bit integer value. Defaults to 1.
+#disable=1
+
+# modifiers
+#
+# Whether or not modifier keys (alt, ctrl, etc) should affect the trackpad
+# state. Boolean value. Defaults to false.
+#modifiers=false
+
+# poll
+#
+# How long (in milliseconds) that dispad will wait after polling the keyboard
+# before polling again. Integer value. Defaults to 100.
+#poll=100
+
+# delay
+#
+# How long after the trackpad(s) should be disabled after a keystroke. Integer value. Defaults to 1000.
+#delay=1000
+
+# pidfile
+#
+# The location of the PID file dispad will create when running. If this option
+# is commented or not present then a PID file will not be created. dispad will
+# remove this file if it shuts down cleanly. If dispad is configured to create
+# a PID file and that PID file already exists it will refuse to start. By
+# default this option is not set.
+pidfile=/run/dispad/dispad.pid
diff --git a/dispad.install b/dispad.install
new file mode 100644
index 000000000000..5d2cac1fea8c
--- /dev/null
+++ b/dispad.install
@@ -0,0 +1,15 @@
+post_install() {
+ printf "\nExample configuration can be found at /etc/dispad/dispad.conf.example and can optionally be copied to ~/.dispad\n"
+ printf "\nTo use dispad, start with:\n"
+ printf "systemctl --user start dispad\n"
+ printf "\nAutostart on login:\n"
+ printf "systemctl --user enable dispad\n"
+ printf "\n"
+}
+
+post_upgrade() {
+ printf "\nRemember to reload systemd user daemons before restarting dispad\n"
+ printf "systemctl --user daemon-reload\n"
+ printf "systemctl --user restart dispad\n"
+ printf "\n"
+}
diff --git a/dispad.service b/dispad.service
new file mode 100644
index 000000000000..2599949fe0e6
--- /dev/null
+++ b/dispad.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=dispad daemon
+
+[Service]
+Type=forking
+ExecStart=/usr/bin/dispad --pidfile=%h/.dispad.pid
+
+[Install]
+WantedBy=multi-user.target