summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Jost2010-10-06 01:58:03 +0200
committerThomas Jost2015-06-11 14:12:55 +0200
commita14fc4a20e295fa76518b71c63046e34cb8c9621 (patch)
tree36d790b4e6cbd1259d664bc28d019a314006bd9e
parent84e0335f12bef2ac4252a00ec03d0ca2b60489a6 (diff)
downloadaur-a14fc4a20e295fa76518b71c63046e34cb8c9621.tar.gz
Python --> python2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0923ec49604..23d7d383b2b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = disper
pkgdesc = An on-the-fly display switch utility, intended to be used on laptops, especially with nVidia cards.
pkgver = 0.2.3
- pkgrel = 1
+ pkgrel = 2
url = http://willem.engen.nl/projects/disper/
arch = any
license = GPL
- depends = python
+ depends = python2
source = https://launchpad.net/~wvengen/+archive/ppa/+files/disper_0.2.3.tar.gz
md5sums = 85b4cde564fc27b7249826e0a4379394
diff --git a/PKGBUILD b/PKGBUILD
index 9e9c928fb0f0..2ae45b410828 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,27 @@
-# Maintainer: Schnouki <thomas.jost@gmail.com>
+# Maintainer: Thomas Jost <schnouki@schnouki.net>
pkgname=disper
pkgver=0.2.3
-pkgrel=1
+pkgrel=2
pkgdesc="An on-the-fly display switch utility, intended to be used on laptops, especially with nVidia cards."
arch=('any')
url="http://willem.engen.nl/projects/disper/"
license=('GPL')
-depends=('python')
+depends=('python2')
source=(https://launchpad.net/~wvengen/+archive/ppa/+files/${pkgname}_${pkgver}.tar.gz)
md5sums=('85b4cde564fc27b7249826e0a4379394')
build() {
cd "$srcdir/trunk"
+ make
+}
- make || return 1
+package() {
+ cd "$srcdir/trunk"
make DESTDIR="$pkgdir" install
-}
+ # Patch to use python2
+ find "$pkgdir" -type f \( -name '*.py' -or -executable \) -exec \
+ sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
+ -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ \{\} +
+}