summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortxtsd2024-03-04 18:10:51 +0530
committertxtsd2024-03-04 18:10:51 +0530
commit6f0ea62510e738e90db80cfacaee81cef702072e (patch)
tree87f9d993a0f0d33240786525cd9d57046e4cd0ff
downloadaur-6f0ea62510e738e90db80cfacaee81cef702072e.tar.gz
upgpkg: dissent-bin 0.0.20-1
Signed-off-by: txtsd <code@ihavea.quest>
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD27
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55e4c48c537a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = dissent-bin
+ pkgdesc = Discord client written in go and gtk4 (binary version)
+ pkgver = 0.0.20
+ pkgrel = 1
+ url = https://github.com/diamondburned/dissent
+ arch = x86_64
+ arch = aarch64
+ license = GPL-3.0-only
+ depends = gtk4>=4.10.3
+ depends = gobject-introspection
+ depends = libadwaita>=1.3.2
+ depends = libgirepository
+ depends = harfbuzz
+ depends = glib2
+ depends = graphene
+ depends = cairo
+ depends = hicolor-icon-theme
+ depends = pango
+ depends = glibc
+ depends = gdk-pixbuf2
+ depends = gcc-libs
+ provides = dissent
+ conflicts = dissent
+ conflicts = dissent-git
+ source_x86_64 = https://github.com/diamondburned/dissent/releases/download/v0.0.20/dissent-linux-amd64-v0.0.20-.tar.zst
+ sha256sums_x86_64 = 70fdd326c071ae2d0e05d4afd10181d1d021c6297afbd6d262d563d4f0f46f2e
+ source_aarch64 = https://github.com/diamondburned/dissent/releases/download/v0.0.20/dissent-linux-arm64-v0.0.20-.tar.zst
+ sha256sums_aarch64 = 8beed2054a973795e7b47387a6fef7981805f68665441aeb9a8242908132de44
+
+pkgname = dissent-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..19fe5ff4ffb4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+
+*.tar.zst
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43799c2a1f9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: esrh - https://esrh.me
+# Maintainer: txtsd <aur.archlinux@ihavea.quest>
+
+pkgname=dissent-bin
+_pkgname=dissent
+_fqpn=so.libdb.${_pkgname}
+pkgver=0.0.20
+pkgrel=1
+pkgdesc='Discord client written in go and gtk4 (binary version)'
+arch=('x86_64' 'aarch64')
+url='https://github.com/diamondburned/dissent'
+license=('GPL-3.0-only')
+provides=('dissent')
+conflicts=('dissent' 'dissent-git')
+depends=('gtk4>=4.10.3' 'gobject-introspection' 'libadwaita>=1.3.2'
+ 'libgirepository' 'harfbuzz' 'glib2' 'graphene' 'cairo'
+ 'hicolor-icon-theme' 'pango' 'glibc' 'gdk-pixbuf2' 'gcc-libs')
+
+sha256sums_x86_64=('70fdd326c071ae2d0e05d4afd10181d1d021c6297afbd6d262d563d4f0f46f2e')
+sha256sums_aarch64=('8beed2054a973795e7b47387a6fef7981805f68665441aeb9a8242908132de44')
+source_x86_64=("https://github.com/diamondburned/dissent/releases/download/v${pkgver}/dissent-linux-amd64-v${pkgver}-.tar.zst")
+source_aarch64=("https://github.com/diamondburned/dissent/releases/download/v${pkgver}/dissent-linux-arm64-v${pkgver}-.tar.zst")
+
+package() {
+ install -Dm 755 "${srcdir}/bin/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ cp -r "${srcdir}/share/" "${pkgdir}/usr/"
+}