summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Sonck2020-08-15 01:44:13 +0200
committerDaniel Sonck2020-08-15 01:44:13 +0200
commit004d0dfa6d89128f21fe88c7a662f4587489848c (patch)
treef673d79d1e892cf93e65d0444c3d37574cdeba89
parentb88f0662beefcf5109681eb397d07579c0982a76 (diff)
downloadaur-distrho-ports-vst-git.tar.gz
Rename package and fix meson build
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 24 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe549fd23fad..15fdd8358fcd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
-pkgbase = distrho-vst-git
+pkgbase = distrho-ports-vst-git
pkgdesc = DISTRHO VST audio plugins ports.
- pkgver = r431.65c7c68a
+ pkgver = r492.062a0f61
pkgrel = 1
url = http://distrho.sourceforge.net/
arch = i686
arch = x86_64
license = GPL
license = LGPL
- makedepends = premake3
makedepends = git
makedepends = libxinerama
makedepends = libxrender
@@ -15,21 +14,22 @@ pkgbase = distrho-vst-git
makedepends = steinberg-vst36
makedepends = ladspa
makedepends = libgl
+ makedepends = meson
depends = freetype2
depends = alsa-lib
depends = libxext
depends = libglvnd
- provides = distrho-vst
- conflicts = distrho-vst
- conflicts = distrho-vst-git
+ provides = distrho-ports-vst
+ conflicts = distrho-ports-vst
conflicts = distrho-plugins-vst-git
conflicts = dexed
conflicts = dexed-git
conflicts = dexed-vst-git
conflicts = luftikus
conflicts = tal-plugins
- source = distrho-vst::git+https://github.com/DISTRHO/DISTRHO-Ports.git
+ replaces = distrho-vst-git
+ source = distrho-ports-vst::git+https://github.com/DISTRHO/DISTRHO-Ports.git
md5sums = SKIP
-pkgname = distrho-vst-git
+pkgname = distrho-ports-vst-git
diff --git a/PKGBUILD b/PKGBUILD
index 3e23650d5297..93f6eac5b0bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
-# Maintainer: CrocoDuck <crocoduck dot oducks at gmail dot com>
+# Maintainer: Daniel Sonck <daniel at sonck dot nl>
+# Contributor : CrocoDuck <crocoduck dot oducks at gmail dot com>
# Contributor : speps <speps at aur dot archlinux dot org>
-pkgname=distrho-vst-git
-pkgver=r431.65c7c68a
+pkgname=distrho-ports-vst-git
+pkgver=r492.062a0f61
pkgrel=1
pkgdesc="DISTRHO VST audio plugins ports."
arch=('i686' 'x86_64')
url="http://distrho.sourceforge.net/"
license=('GPL' 'LGPL')
depends=('freetype2' 'alsa-lib' 'libxext' 'libglvnd')
-makedepends=('premake3' 'git' 'libxinerama' 'libxrender' 'libxcursor' 'steinberg-vst36' 'ladspa' 'libgl')
+makedepends=('git' 'libxinerama' 'libxrender' 'libxcursor' 'steinberg-vst36' 'ladspa' 'libgl' 'meson')
provides=("${pkgname%-*}")
-conflicts=("${pkgname%-*}" "distrho-vst-git" "distrho-plugins-vst-git" "dexed" "dexed-git" "dexed-vst-git" "luftikus" "tal-plugins")
+replaces=("distrho-vst-git")
+conflicts=("${pkgname%-*}" "distrho-plugins-vst-git" "dexed" "dexed-git" "dexed-vst-git" "luftikus" "tal-plugins")
source=("${pkgname%-*}"::'git+https://github.com/DISTRHO/DISTRHO-Ports.git')
md5sums=('SKIP')
@@ -22,19 +24,20 @@ pkgver() {
prepare() {
mkdir -p "${pkgname%-*}"/sdks/vstsdk2.4/public.sdk/source
- ln -rsf /usr/include/vst36/ "${pkgname%-*}"/sdks/vstsdk2.4/public.sdk/source/vst2.x
- ln -rsf /usr/include/vst36/pluginterfaces/ "${pkgname%-*}"/sdks/vstsdk2.4/pluginterfaces
+ ln -rsfT /usr/include/vst36/ "${pkgname%-*}"/sdks/vstsdk2.4/public.sdk/source/vst2.x
+ ln -rsfT /usr/include/vst36/pluginterfaces/ "${pkgname%-*}"/sdks/vstsdk2.4/pluginterfaces
}
build() {
cd "${pkgname%-*}"
- ./scripts/premake-update.sh linux
- make vst
+ meson build --buildtype release
+ meson configure build -Dprefix="/usr" -Dbuild-vst2=true -Dbuild-vst3=true -Dbuild-lv2=false
+ ninja -C build
}
package() {
- cd "${pkgname%-*}"/bin/vst
- for i in *; do
- install -D "$i" "$pkgdir/usr/lib/vst/$i"
- done
+ cd "${srcdir}/${pkgname%-*}"
+
+ DESTDIR="${pkgdir}" ninja -C build install
+ rm -rf "${pkgdir}/usr/lib/lv2"
}