summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCrocoDuck2016-01-17 15:02:39 +0000
committerCrocoDuck2016-01-17 15:02:39 +0000
commit4cdd62319b6fbd2c755ce7422f2ef750da4aef22 (patch)
tree6fded9fdf12e6f575541e205641bbc964c20c119
downloadaur-4cdd62319b6fbd2c755ce7422f2ef750da4aef22.tar.gz
Initial import
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD34
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f82aecce824
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Sun Jan 17 14:54:48 UTC 2016
+pkgbase = distrho-vst-git
+ pkgdesc = DISTRHO VST audio plugins ports
+ pkgver = r336.7bcbc9b
+ pkgrel = 1
+ url = http://distrho.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = premake3
+ makedepends = git
+ makedepends = libxinerama
+ makedepends = libxrender
+ makedepends = libxcursor
+ makedepends = steinberg-vst36
+ depends = freetype2
+ depends = alsa-lib
+ depends = libxext
+ provides = distrho-vst-git
+ conflicts = distrho-vst-git
+ conflicts = distrho-vst
+ conflicts = distrho-plugins-vst-git
+ source = distrho-vst-git::git://github.com/DISTRHO/DISTRHO-Ports
+ md5sums = SKIP
+
+pkgname = distrho-vst-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0b940528b3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: CrocoDuck <crocoduck.oducks@gmail.com>
+# Contributor : speps <speps at aur dot archlinux dot org>
+
+pkgname=distrho-vst-git
+pkgver=r336.7bcbc9b
+pkgrel=1
+pkgdesc="DISTRHO VST audio plugins ports"
+arch=('i686' 'x86_64')
+url="http://distrho.sourceforge.net/"
+license=('GPL' 'LGPL')
+depends=('freetype2' 'alsa-lib' 'libxext')
+makedepends=('premake3' 'git' 'libxinerama' 'libxrender' 'libxcursor' 'steinberg-vst36')
+provides=("${pkgname}")
+conflicts=("${pkgname}" "distrho-vst" "distrho-plugins-vst-git")
+source=("${pkgname}::git://github.com/DISTRHO/DISTRHO-Ports")
+md5sums=('SKIP')
+
+prepare() {
+ mkdir -p "$pkgname"/sdks/vstsdk2.4/public.sdk/source
+ ln -rsf /usr/include/vst36/ "$pkgname"/sdks/vstsdk2.4/public.sdk/source/vst2.x
+ ln -rsf /usr/include/vst36/pluginterfaces/ "$pkgname"/sdks/vstsdk2.4/pluginterfaces
+}
+
+build() {
+ cd "$pkgname"
+ ./scripts/premake-update.sh linux
+ make vst
+}
+
+package() {
+ cd "$pkgname"
+ install -d bin/vst/ "$pkgdir"/usr/lib/vst/
+ cp -a bin/vst/. "$pkgdir"/usr/lib/vst/
+}