summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergej Pupykin2023-07-28 23:40:32 +0300
committerSergej Pupykin2023-07-28 23:40:32 +0300
commit40fdd9722c60c2ba6c45ef045430ef80831835a9 (patch)
tree664f7c986f5ec734e8f69c2882f1166e227d87ba
downloadaur-40fdd9722c60c2ba6c45ef045430ef80831835a9.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb7818735b73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = distribution
+ pkgdesc = the Open Source Registry implementation for storing and distributing container images using the OCI Distribution Specification
+ pkgver = 2.8.2git
+ pkgrel = 1
+ url = https://github.com/distribution/distribution/
+ arch = x86_64
+ license = GPL
+ makedepends = go
+ depends = go
+ depends = git
+ source = git+https://github.com/distribution/distribution.git
+ sha256sums = SKIP
+
+pkgname = distribution
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4da48f7be63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=distribution
+pkgver=2.8.2git # fails to build from tag
+pkgrel=1
+pkgdesc="the Open Source Registry implementation for storing and distributing container images using the OCI Distribution Specification"
+arch=(x86_64)
+url="https://github.com/distribution/distribution/"
+license=('GPL')
+depends=('go' 'git')
+makedepends=('go')
+#source=("git+https://github.com/distribution/distribution.git#tag=v$pkgver")
+source=("git+https://github.com/distribution/distribution.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+# go mod init "github.com/distribution/distribution"
+# go mod vendor
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm0755 bin/digest "$pkgdir"/usr/bin/digest
+ install -Dm0755 bin/registry "$pkgdir"/usr/bin/registry
+ install -Dm0755 bin/registry-api-descriptor-template "$pkgdir"/usr/bin/registry-api-descriptor-template
+}