summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia2023-11-05 18:28:05 +0100
committerClaudia2023-11-05 18:51:08 +0100
commit100939ddf117c5413b7cc39f44bc010f7e1c70c0 (patch)
tree88ee144d868acca6c70abdc935743c9020e50ac4
parent9b3f04fb7278a0c25a310f64982cbaa5bd3627b3 (diff)
downloadaur-100939ddf117c5413b7cc39f44bc010f7e1c70c0.tar.gz
Update to v1.7
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD36
3 files changed, 32 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65e4785218c7..478347c76448 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = distro-info
pkgdesc = provides information about the distributions' releases
- pkgver = 1.4
+ pkgver = 1.7
pkgrel = 1
url = http://packages.debian.org/sid/distro-info
arch = i686
arch = x86_64
license = MIT
- makedepends = shunit2
- makedepends = perl
- makedepends = python-setuptools
- makedepends = python2-setuptools
- makedepends = python-pylint
- depends = distro-info-data>=0.56
+ checkdepends = python-setuptools
+ checkdepends = shunit2
+ makedepends = dpkg
+ depends = distro-info-data>=0.59
+ depends = glibc
+ depends = python
provides = python-distro-info
provides = python3-distro-info
provides = perl-distro-info
@@ -19,7 +19,7 @@ pkgbase = distro-info
conflicts = python3-distro-info
conflicts = perl-distro-info
options = !emptydirs
- source = http://ftp.debian.org/debian/pool/main/d/distro-info/distro-info_1.4.tar.xz
- sha256sums = d5c77a199a5287fd18afb0f32377b3516d680f60e055d18a9fea423ceb2e4c27
+ source = http://ftp.debian.org/debian/pool/main/d/distro-info/distro-info_1.7.tar.xz
+ sha256sums = 6fa91b888320b74cd4391941092601a9bc33f3427d1d0ba93efcb7f31bcecf7e
pkgname = distro-info
diff --git a/.gitignore b/.gitignore
index bd9b4a41adc0..16fbc074ade0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+*.log
*.tar.gz
*.tar.xz
*.tgz
diff --git a/PKGBUILD b/PKGBUILD
index b830394dbf1f..48cd29ea683c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,52 @@
+# Maintainer: Claudia Pellegrino <aur ät cpellegrino.de>
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=distro-info
-_python=python3
-pkgver=1.4
+pkgver=1.7
pkgrel=1
pkgdesc="provides information about the distributions' releases"
arch=('i686' 'x86_64')
url="http://packages.debian.org/sid/distro-info"
license=('MIT')
-depends=('distro-info-data>=0.56')
-makedepends=('shunit2' 'perl' 'python-setuptools' 'python2-setuptools' 'python-pylint')
+depends=('distro-info-data>=0.59' 'glibc' 'python')
+makedepends=('dpkg')
+checkdepends=('python-setuptools' 'shunit2')
provides=('python-distro-info' 'python3-distro-info' 'perl-distro-info')
conflicts=('python-distro-info' 'python3-distro-info' 'perl-distro-info')
-options=(!emptydirs)
+options=('!emptydirs')
source=(http://ftp.debian.org/debian/pool/main/d/$pkgname/${pkgname}_$pkgver.tar.xz)
-sha256sums=('d5c77a199a5287fd18afb0f32377b3516d680f60e055d18a9fea423ceb2e4c27')
+sha256sums=('6fa91b888320b74cd4391941092601a9bc33f3427d1d0ba93efcb7f31bcecf7e')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i \
+ -e 's/^\(LDFLAGS = .*\)/\1 '"${LDFLAGS}/" \
+ -e 's/ --install-layout=deb//g' \
+ Makefile
+}
build() {
- #cd "$srcdir/$pkgname-$pkgver"
- cd "$srcdir/$pkgname"
- sed -i -e 's/ --install-layout=deb//g' Makefile
+ cd "$srcdir/$pkgname-$pkgver"
make
}
+
check() {
- #cd "$srcdir/$pkgname-$pkgver"
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
make test-commandline
make test-perl
- cd python
# We don't want to test all installed python versions -> don't use "make test"
# additionally the pylint and flake8 tests seem to fail currently
+ #cd python
#for pythonver in {python2,python}; do
# $pythonver setup.py test
#done
}
+
package() {
- #cd "$srcdir/$pkgname-$pkgver"
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
# vendor can currently be only ubuntu or debian
# with ubuntu you can build for PPA (with bzr-builddeb)
make DESTDIR="$pkgdir/" VENDOR="ubuntu" install
+ install -D -m 644 debian/copyright "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et: