summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2013-04-10 01:14:24 +0200
committerJohannes Dewender2013-04-10 01:14:24 +0200
commita6cd19eb70f5aca501405d9b94809503fcf6e4fb (patch)
tree10d10c6b5b5182f68625a7572fdcad35d3a83f5d
downloadaur-a6cd19eb70f5aca501405d9b94809503fcf6e4fb.tar.gz
distro-info: created as 0.10
This package also includes the perl and python bindings.
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD42
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b66dbf83e715
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = distro-info
+ pkgdesc = provides information about the distributions' releases
+ pkgver = 0.10
+ pkgrel = 1
+ url = http://packages.debian.org/sid/reportbug
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = shunit2
+ makedepends = perl
+ makedepends = python-distribute
+ makedepends = python2-distribute
+ depends = distro-info-data
+ provides = python-distro-info
+ provides = python2-distro-info
+ provides = perl-distro-info
+ conflicts = python-distro-info
+ conflicts = python2-distro-info
+ conflicts = perl-distro-info
+ options = !emptydirs
+ source = http://ftp.debian.org/debian/pool/main/d/distro-info/distro-info_0.10.tar.gz
+ md5sums = 1befc0430158f62a13a3c01ce4586ed5
+
+pkgname = distro-info
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bd9b4a41adc0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.tar.gz
+*.tar.xz
+*.tgz
+*.rpm
+*.zip
+*.bz2
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b76493f7938
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Contributor: Johannes Dewender arch at JonnyJD dot net
+pkgname=distro-info
+_python=python2
+pkgver=0.10
+pkgrel=1
+pkgdesc="provides information about the distributions' releases"
+arch=('i686' 'x86_64')
+url="http://packages.debian.org/sid/reportbug"
+license=('MIT')
+depends=('distro-info-data')
+makedepends=('shunit2' 'perl' 'python-distribute' 'python2-distribute')
+provides=('python-distro-info' 'python2-distro-info' 'perl-distro-info')
+conflicts=('python-distro-info' 'python2-distro-info' 'perl-distro-info')
+options=(!emptydirs)
+source=(http://ftp.debian.org/debian/pool/main/d/$pkgname/${pkgname}_$pkgver.tar.gz)
+md5sums=('1befc0430158f62a13a3c01ce4586ed5')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i -e 's/python3 setup.py/python2 setup.py/g' \
+ -e 's/ --install-layout=deb//g' \
+ Makefile
+ make
+}
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make test-commandline
+ make test-perl
+ cd python
+ # We don't want to test all installed python versions -> don't use "make test"
+ for pythonver in {python2,python}; do
+ $pythonver setup.py test
+ done
+}
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # vendor can currently be only ubuntu or debian
+ # with ubuntu you can build for PPA (with bzr-builddeb)
+ make DESTDIR="$pkgdir/" VENDOR="ubuntu" install
+}
+
+# vim:set ts=2 sw=2 et: