summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2013-04-10 01:08:21 +0200
committerJohannes Dewender2013-04-10 01:08:21 +0200
commit049f0ab274f6d6f4329c3fbc8f7c0d2fdbfc5b1d (patch)
treea0432f5fd76f3c6f263986443a267f49d697b588
downloadaur-049f0ab274f6d6f4329c3fbc8f7c0d2fdbfc5b1d.tar.gz
distro-info-data: created as 0.13
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD30
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e32a5484181
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = distro-info-data
+ pkgdesc = information about the distributions' releases (data files)
+ pkgver = 0.13
+ pkgrel = 1
+ url = http://packages.debian.org/sid/distro-info-data
+ arch = any
+ license = MIT
+ makedepends = python2
+ options = !emptydirs
+ source = http://ftp.debian.org/debian/pool/main/d/distro-info-data/distro-info-data_0.13.tar.gz
+ md5sums = 4e2fdb6691244dc2e6bdb4ef3ad8ccbb
+
+pkgname = distro-info-data
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bd9b4a41adc0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.tar.gz
+*.tar.xz
+*.tgz
+*.rpm
+*.zip
+*.bz2
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04332a2e209e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Johannes Dewender arch at JonnyJD dot net
+pkgname=distro-info-data
+pkgver=0.13
+pkgrel=1
+pkgdesc="information about the distributions' releases (data files)"
+arch=('any')
+url="http://packages.debian.org/sid/distro-info-data"
+license=('MIT')
+depends=()
+makedepends=('python2')
+options=(!emptydirs)
+source=(http://ftp.debian.org/debian/pool/main/d/$pkgname/${pkgname}_$pkgver.tar.gz)
+md5sums=('4e2fdb6691244dc2e6bdb4ef3ad8ccbb')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i '1s/python$/python2/' validate-csv-data
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make test
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: