summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEnmanuel2022-05-01 20:44:17 +0000
committerEnmanuel2022-05-01 20:44:17 +0000
commit22c680672e2e0594d700954ff9f18c89365f7417 (patch)
treebc07248c59d470a0f37f93d403de787cb64b6501
downloadaur-22c680672e2e0594d700954ff9f18c89365f7417.tar.gz
Updating to version 4.20.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0cad3b57aa7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = diun
+ pkgdesc = Receive notifications when an image is updated on a Docker registry.
+ pkgver = 4.20.0
+ pkgrel = 1
+ url = https://github.com/crazy-max/diun
+ arch = x86_64
+ license = MIT
+ source = diun-4.20.0_linux_amd64.tar.gz::https://github.com/crazy-max/diun/releases/download/v4.20.0/diun_4.20.0_linux_amd64.tar.gz
+ sha256sums = 1818c5f791c1c4e756c48ad1fe8f8fbd0c42280da68d8dc4f4f790ab0cbb0c10
+
+pkgname = diun
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ffb7f7f84a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Enmanuel Moreira <enmanuelmoreira@gmail.com>
+
+pkgname=diun
+pkgver=4.20.0
+pkgrel=1
+pkgdesc="Receive notifications when an image is updated on a Docker registry."
+arch=('x86_64')
+url="https://github.com/crazy-max/diun"
+license=('MIT')
+source=("${pkgname}-${pkgver}_linux_amd64.tar.gz::https://github.com/crazy-max/${pkgname}/releases/download/v${pkgver}/${pkgname}_${pkgver}_linux_amd64.tar.gz")
+sha256sums=('1818c5f791c1c4e756c48ad1fe8f8fbd0c42280da68d8dc4f4f790ab0cbb0c10')
+
+package() {
+ cd "${srcdir}"
+ install -Dm755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ install -Dm644 README.md ${pkgdir}/usr/share/doc/${pkgname}/README.md
+ install -Dm644 LICENSE ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+ install -Dm644 CHANGELOG.md ${pkgdir}/usr/share/doc/${pkgname}/CHANGELOG.md
+}