summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEnmanuel2023-09-30 23:10:58 +0000
committerEnmanuel2023-09-30 23:10:58 +0000
commitb3a89865aeb5ab842bbc54a56023e1cd570507a7 (patch)
treedbd726eb748ee4eca3160c9dcf45358d907e5dcc
parent0bf350ef491e4d71209afe10504afd1dd857ca8f (diff)
downloadaur-b3a89865aeb5ab842bbc54a56023e1cd570507a7.tar.gz
Fix package release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 23 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2b92f826d82..ac79e0a30eb0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = diun
pkgdesc = Receive notifications when an image is updated on a Docker registry.
pkgver = 4.26.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/crazy-max/diun
arch = x86_64
license = MIT
@@ -14,7 +14,9 @@ pkgbase = diun
conflicts = diun-bin
source = diun-4.26.0.tar.gz::https://github.com/crazy-max/diun/archive/v4.26.0.tar.gz
source = diun.service::https://gitlab.com/mapanare-labs/packages/archlinux/diun-bin/-/raw/main/diun.service
+ source = diun.yml::https://gitlab.com/mapanare-labs/packages/archlinux/diun-bin/-/raw/main/diun.yml
sha256sums = 72cb054b2be7747c0b870310732cb568df0773cd1d788aa6bb8cd05024fcd019
- sha256sums = 902084dd9bb29d19bd27de9ca6030781a7582a2353c1eeb3a9b2e5e86707a1e3
+ sha256sums = 5c16f7ae5b023407a443fbf1d0d811d236c94d191aae1af426e9540d22df3fa7
+ sha256sums = 00436d3e95e446211f9ffbaa36e6b9bc27ffe054745f1a687c4c1c46f1d7da14
pkgname = diun
diff --git a/PKGBUILD b/PKGBUILD
index 112096db4cd7..00354b4d3dea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=diun
pkgver=4.26.0
-pkgrel=2
+pkgrel=3
pkgdesc="Receive notifications when an image is updated on a Docker registry."
arch=('x86_64')
url="https://github.com/crazy-max/diun"
@@ -11,12 +11,14 @@ provides=('diun')
license=('MIT')
makedepends=('go>=1.17' 'git' 'gzip' 'tar' 'gcc')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/crazy-max/${pkgname}/archive/v${pkgver}.tar.gz"
- "diun.service::https://gitlab.com/mapanare-labs/packages/archlinux/diun-bin/-/raw/main/diun.service")
+ "diun.service::https://gitlab.com/mapanare-labs/packages/archlinux/diun-bin/-/raw/main/diun.service"
+ "diun.yml::https://gitlab.com/mapanare-labs/packages/archlinux/diun-bin/-/raw/main/diun.yml")
sha256sums=('72cb054b2be7747c0b870310732cb568df0773cd1d788aa6bb8cd05024fcd019'
- '902084dd9bb29d19bd27de9ca6030781a7582a2353c1eeb3a9b2e5e86707a1e3')
+ '5c16f7ae5b023407a443fbf1d0d811d236c94d191aae1af426e9540d22df3fa7'
+ '00436d3e95e446211f9ffbaa36e6b9bc27ffe054745f1a687c4c1c46f1d7da14')
build() {
- mv diun.service "${pkgname}-${pkgver}/"
+ mv diun.service diun.yml "${pkgname}-${pkgver}/"
cd "${pkgname}-${pkgver}"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
@@ -29,9 +31,20 @@ build() {
package() {
cd "${srcdir}"/"${pkgname}-${pkgver}"
- install -Dm755 build/"${pkgname}" "${pkgdir}"/usr/local/bin/"${pkgname}"
+ install -Dm755 build/"${pkgname}" "${pkgdir}"/usr/bin/"${pkgname}"
install -Dm755 diun.service ${pkgdir}/etc/systemd/system/diun.service
+ install -Dm644 diun.yml ${pkgdir}/etc/diun/diun.yml
install -Dm644 README.md ${pkgdir}/usr/share/doc/${pkgname}/README.md
- install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 LICENSE ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
install -Dm644 CHANGELOG.md ${pkgdir}/usr/share/doc/${pkgname}/CHANGELOG.md
}
+
+post_install() {
+ echo 'Default configuration file `/etc/diun/diun.yml` is included in this package.'
+ echo 'You must modify it with you own configuration following the Diun documentation.'
+ echo 'See https://crazymax.dev/diun/config/ for more details.'
+ echo ''
+ echo 'Once the configuration is in place, you can start the Diun system'
+ echo 'service or enable it to run on boot like with any other service, e.g.'
+ echo '# systemctl enable --now diun.service'
+}