summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Birks2019-07-16 02:28:59 -0400
committerDavid Birks2019-07-16 02:28:59 -0400
commit076659685f1e9216f8a270ac37a7ea212ac9e436 (patch)
treed7cd29929fbde8821ff83729b0898c69da4b533c
parent945aa6e022c2e0af61ce656c22cb336b570f9f45 (diff)
downloadaur-076659685f1e.tar.gz
Fix version not outputting
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD15
2 files changed, 6 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9991ae638c43..2d9fd5e5cc5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,10 +6,9 @@ pkgbase = dive
arch = x86_64
license = MIT
makedepends = go
- makedepends = git
depends = docker
conflicts = dive-git
- source = https://github.com/wagoodman/dive/archive/v0.7.2.tar.gz
+ source = dive-0.7.2.tar.gz::https://github.com/wagoodman/dive/archive/v0.7.2.tar.gz
sha256sums = 2ec6d77b662e0d709f6fc4282dbd8f0d3f6509f78133451b6b17d9b8fb594cf1
pkgname = dive
diff --git a/PKGBUILD b/PKGBUILD
index 2a3eccb10122..27aa62e5dd56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,24 +9,19 @@ url='https://github.com/wagoodman/dive'
arch=('x86_64')
license=('MIT')
depends=('docker')
-makedepends=('go' 'git')
+makedepends=('go')
conflicts=('dive-git')
-source=("https://github.com/wagoodman/dive/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/wagoodman/dive/archive/v$pkgver.tar.gz")
sha256sums=('2ec6d77b662e0d709f6fc4282dbd8f0d3f6509f78133451b6b17d9b8fb594cf1')
build() {
# Trim pwd from path
- export GOFLAGS="-gcflags=all=-trimpath=${PWD} -asmflags=all=-trimpath=${PWD}"
+ export GOFLAGS="-gcflags=all=-trimpath=${PWD} -asmflags=all=-trimpath=${PWD} -ldflags=-extldflags=-zrelro -ldflags=-extldflags=-znow"
cd $pkgname-$pkgver
- make build
-}
-
-check() {
- cd $pkgname-$pkgver
- make test
+ go build --ldflags "-X main.version=$pkgver" .
}
package() {
- install -Dm 755 "${srcdir}/$pkgname-$pkgver/build/dive" "${pkgdir}/usr/bin/dive"
+ install -Dm 755 "$srcdir/$pkgname-$pkgver/dive" "$pkgdir/usr/bin/dive"
}