summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-12-30 22:05:44 +0100
committerJ5lx2015-12-30 22:05:44 +0100
commit7955bbc747a7fd1cc289d4785d586c9d9fde3674 (patch)
treee31694ffebab5e7dba3ca199bcdf429c66287312
downloadaur-7955bbc747a7fd1cc289d4785d586c9d9fde3674.tar.gz
0.24.1-1: Initial package
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD36
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fbb7face21cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+# Generated by mksrcinfo v8
+# Wed Dec 30 21:05:25 UTC 2015
+pkgbase = django-allauth
+ pkgdesc = Integrated set of Django applications addressing authentication, registration, account management as well as 3rd party (social) account authentication.
+ pkgver = 0.24.1
+ pkgrel = 1
+ url = http://www.intenct.nl/projects/django-allauth/
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = python-django
+ makedepends = python-openid
+ makedepends = python-requests-oauthlib
+ makedepends = python-requests
+ makedepends = python2
+ makedepends = python2-setuptools
+ makedepends = python2-django
+ makedepends = python2-openid
+ makedepends = python2-requests-oauthlib
+ makedepends = python2-requests
+ source = https://github.com/pennersr/django-allauth/archive/0.24.1.tar.gz
+ md5sums = 5bcece1721fcf1f05f5df2d8b36ae7dc
+
+pkgname = python-django-allauth
+ depends = python
+ depends = python-django
+ depends = python-openid
+ depends = python-requests-oauthlib
+ depends = python-requests
+
+pkgname = python2-django-allauth
+ depends = python2
+ depends = python2-django
+ depends = python2-openid
+ depends = python2-requests-oauthlib
+ depends = python2-requests
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95003de37109
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgbase=django-allauth
+pkgname=('python-django-allauth' 'python2-django-allauth')
+pkgver=0.24.1
+pkgrel=1
+pkgdesc="Integrated set of Django applications addressing authentication, registration, account management as well as 3rd party (social) account authentication."
+arch=('any')
+license=('MIT')
+url="http://www.intenct.nl/projects/django-allauth/"
+makedepends=('python' 'python-setuptools' 'python-django' 'python-openid'
+ 'python-requests-oauthlib' 'python-requests' 'python2'
+ 'python2-setuptools' 'python2-django' 'python2-openid'
+ 'python2-requests-oauthlib' 'python2-requests')
+source=("https://github.com/pennersr/${pkgbase}/archive/${pkgver}.tar.gz")
+md5sums=('5bcece1721fcf1f05f5df2d8b36ae7dc')
+
+package_python-django-allauth() {
+ depends=('python' 'python-django' 'python-openid' 'python-requests-oauthlib'
+ 'python-requests')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+
+ python setup.py install --root="${pkgdir}" -O1
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_python2-django-allauth() {
+ depends=('python2' 'python2-django' 'python2-openid'
+ 'python2-requests-oauthlib' 'python2-requests')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+
+ python2 setup.py install --root="${pkgdir}" -O1
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}