summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlias Stamatis2015-09-06 17:48:43 +0300
committerIlias Stamatis2015-09-06 17:48:43 +0300
commit2050a68a4597e39603a7cd32c3a48c6e0cb7bd07 (patch)
tree2c1fb3d773d7d92a05e9bfa0e70c26863914a06b
downloadaur-2050a68a4597e39603a7cd32c3a48c6e0cb7bd07.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD25
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..704ea0546520
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = django-bootstrap-form-git
+ pkgdesc = A simple Django template tag to work with Bootstrap
+ pkgver = 1.4.r121.g629d82d
+ pkgrel = 1
+ url = https://github.com/tzangms/django-bootstrap-form
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = python-django
+ source = django-bootstrap-form-git::git+https://github.com/tzangms/django-bootstrap-form.git
+ sha256sums = SKIP
+
+pkgname = django-bootstrap-form-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a6832b4db47b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar.gz
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc3cf631623b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ilias Stamatis <stamatis.iliass at gmail dot com>
+
+pkgname=django-bootstrap-form-git
+pkgver=1.4.r121.g629d82d
+pkgrel=1
+pkgdesc="A simple Django template tag to work with Bootstrap"
+arch=('any')
+url='https://github.com/tzangms/django-bootstrap-form'
+license=('BSD')
+depends=('python-django')
+makedepends=('git')
+source=("${pkgname}::git+https://github.com/tzangms/django-bootstrap-form.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ # cutting off 'v' prefix that presents in the git tag
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}