summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron France2015-09-02 18:31:17 +0200
committerAaron France2015-09-02 18:31:17 +0200
commite5a4a6d34f93fd57792e3fafa36236aaeb33af0c (patch)
tree404fa68862fe24c45a130baa52a19203a4e10cb3
downloadaur-django-lint.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD23
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6c9e4cd1056
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = django-lint
+ pkgdesc = A static analysis tool for Django projects.
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/lamby/django-lint
+ arch = any
+ license = GPLv3
+ provides = django-lint
+ source = git://github.com/lamby/django-lint.git
+ md5sums = SKIP
+
+pkgname = django-lint
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9a816868fbb0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/*
+relx*
+src/*
+django-lint/*
+*.xz
+*.gz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e4639257239
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Aaron France <aaron.l.france@gmail.com>
+
+pkgname=django-lint
+pkgrel=1
+pkgver=1
+pkgdesc="A static analysis tool for Django projects."
+license=('GPLv3')
+arch=('any')
+url="https://github.com/lamby/django-lint"
+provides=("django-lint")
+source=('git://github.com/lamby/django-lint.git')
+makedepdends=('git')
+md5sums=('SKIP')
+_gitname=django-lint
+
+build() {
+ return 0
+}
+
+package() {
+ cd $_gitname
+ python2 ./setup.py install --root=$pkgdir || return 1
+} \ No newline at end of file