summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryardenac2013-05-09 16:26:14 -0700
committeryardenac2013-05-09 16:26:14 -0700
commit93630233facbb2fd22384f1b331f98336ba9c583 (patch)
tree8c2f715f0e6a15b6d902dfff3a517d00cc744245
downloadaur-93630233facbb2fd22384f1b331f98336ba9c583.tar.gz
make subdir for packages
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de72e8e849f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = django-storages-hg
+ pkgdesc = Collection of custom storage backends for Django
+ pkgver = 280
+ pkgrel = 1
+ url = http://code.larlet.fr/django-storages/
+ arch = any
+ license = BSD3
+ makedepends = mercurial
+ depends = python2-django
+ depends = python2-boto
+
+pkgname = django-storages-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62ac476f7e1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=django-storages-hg
+pkgver=280
+pkgrel=1
+pkgdesc="Collection of custom storage backends for Django"
+arch=('any')
+url="http://code.larlet.fr/django-storages/"
+license=('BSD3')
+depends=('python2-django' 'python2-boto')
+makedepends=('mercurial')
+
+_hgroot="https://bitbucket.org/david/django-storages"
+_hgrepo="django-storages"
+_hgbranch="default"
+
+build() {
+ hg --cwd ${_hgrepo} update -C || \
+ hg clone -b ${_hgbranch} "${_hgroot}/${_hgrepo}" ${_hgrepo}
+ cd ${_hgrepo}
+ if (( $(hg id -n) < $(hg id -nr ${_hgbranch}) )); then
+ printf 'You are not building the latest revision!\n'
+ printf "Consider updating _hgrev to $(hg id -r ${_hgbranch}).\n"
+ fi
+ python2 setup.py build
+}
+
+package() {
+ cd ${_hgrepo}
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}