summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordan2014-09-17 13:39:21 +0000
committersvntogit2014-09-17 13:39:21 +0000
commit08a507b55dd6f26312c06a8f64531132cf9007cb (patch)
tree63d851aac574c4e2102817693e6f0c0796e4dca0
parent0995ca27639e98504abdd6a5c7a168188896af5b (diff)
downloadaur-08a507b55dd6f26312c06a8f64531132cf9007cb.tar.gz
upgpkg: django 1.7-1
git-svn-id: file:///srv/repos/svn-packages/svn@221841 eb2447ed-0c53-47e4-bac8-5bc4a241df78
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
2 files changed, 21 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a76100b596d0..70cdd9c1cabc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@
# Wed Dec 30 18:02:57 UTC 2015
pkgbase = django
pkgdesc = A high-level Python Web framework that encourages rapid development and clean design
- pkgver = 1.6.6
+ pkgver = 1.7
pkgrel = 1
url = http://www.djangoproject.com/
arch = any
@@ -11,9 +11,9 @@ pkgbase = django
makedepends = python2-setuptools
makedepends = python
makedepends = python-setuptools
- source = https://www.djangoproject.com/m/releases/1.6/Django-1.6.6.tar.gz
- md5sums = d14fd332f31799fff39acc0c79e8421c
- sha256sums = 536cbd54e533ba3563d205f0c91988b24e7d74b8b253d7825e42214b50ba7e90
+ source = https://www.djangoproject.com/m/releases/1.7/Django-1.7.tar.gz
+ md5sums = 03edab6828119aa9b32b2252d25eb38d
+ sha256sums = 33f781f17f145f79ee8e0b8d753498e0e0188f0b53b2accad4045d623422d5e1
pkgname = python-django
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 8844e4bb3798..9d339da1f6fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=django
pkgname=('python-django' 'python2-django')
-pkgver=1.6.6
+pkgver=1.7
pkgrel=1
pkgdesc="A high-level Python Web framework that encourages rapid development and clean design"
arch=('any')
@@ -12,8 +12,8 @@ license=('BSD')
url="http://www.djangoproject.com/"
makedepends=('python2' 'python2-setuptools' 'python' 'python-setuptools')
source=("https://www.djangoproject.com/m/releases/${pkgver:0:3}/Django-$pkgver.tar.gz")
-md5sums=('d14fd332f31799fff39acc0c79e8421c')
-sha256sums=('536cbd54e533ba3563d205f0c91988b24e7d74b8b253d7825e42214b50ba7e90')
+md5sums=('03edab6828119aa9b32b2252d25eb38d')
+sha256sums=('33f781f17f145f79ee8e0b8d753498e0e0188f0b53b2accad4045d623422d5e1')
prepare() {
cp -a "$srcdir/Django-$pkgver" "$srcdir/Django-$pkgver-python2"
@@ -36,11 +36,14 @@ package_python-django() {
cd "$srcdir/Django-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
- mv "$pkgdir"/usr/bin/django-admin.py "$pkgdir"/usr/bin/django-admin3.py
+ ln -s django-admin.py "$pkgdir"/usr/bin/django-admin3.py
+ ln -s django-admin "$pkgdir"/usr/bin/django-admin3
install -Dm644 extras/django_bash_completion \
- "$pkgdir"/usr/share/bash-completion/completions/django-admin3.py
- sed -i -e "s/django-admin.py/django-admin3.py/g" \
- "$pkgdir"/usr/share/bash-completion/completions/django-admin3.py
+ "$pkgdir"/usr/share/bash-completion/completions/django-admin.py
+ ln -s django-admin.py \
+ "$pkgdir"/usr/share/bash-completion/completions/django-admin
+ ln -s django-admin.py \
+ "$pkgdir"/usr/share/bash-completion/completions/manage.py
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
@@ -54,11 +57,14 @@ package_python2-django() {
cd "$srcdir/Django-$pkgver-python2"
python2 setup.py install --root="$pkgdir" --optimize=1
- ln -s django-admin.py "$pkgdir"/usr/bin/django-admin2.py
+ mv "$pkgdir"/usr/bin/django-admin.py "$pkgdir"/usr/bin/django-admin2.py
+ mv "$pkgdir"/usr/bin/django-admin "$pkgdir"/usr/bin/django-admin2
+ # TODO: this probably won't work due to the `complete` command within not
+ # knowing about modified our exectuable names
install -Dm644 extras/django_bash_completion \
- "$pkgdir"/usr/share/bash-completion/completions/django-admin.py
- ln -s django-admin.py \
- "$pkgdir"/usr/share/bash-completion/completions/manage.py
+ "$pkgdir"/usr/share/bash-completion/completions/django-admin2.py
+ ln -s django-admin2.py \
+ "$pkgdir"/usr/share/bash-completion/completions/django-admin2
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}