summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordan2015-01-03 16:23:41 +0000
committersvntogit2015-01-03 16:23:41 +0000
commite5b6cc12c5f80874712982d309f0ee625b8bc685 (patch)
tree23aecba63a08b4f323d5837cd5be3a4224cf0b35
parent084bcc7e616a415bb7145e0598bdfe882fd81edf (diff)
downloadaur-e5b6cc12c5f80874712982d309f0ee625b8bc685.tar.gz
upgpkg: django 1.7.2-1
git-svn-id: file:///srv/repos/svn-packages/svn@228399 eb2447ed-0c53-47e4-bac8-5bc4a241df78
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f0ce4c17f0c..ea836aedd637 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@
# Wed Dec 30 18:02:57 UTC 2015
pkgbase = django
pkgdesc = A high-level Python Web framework that encourages rapid development and clean design
- pkgver = 1.7.1
+ pkgver = 1.7.2
pkgrel = 1
url = http://www.djangoproject.com/
arch = any
@@ -11,16 +11,18 @@ pkgbase = django
makedepends = python2-setuptools
makedepends = python
makedepends = python-setuptools
- source = https://www.djangoproject.com/m/releases/1.7/Django-1.7.1.tar.gz
- md5sums = 81dae89f21647b9aa5c46c6b7dbfa349
- sha256sums = 3de62e71ce2cfbcdecb6e344cad04948506c8410ea5c6eab15c8f3b31b8ac1c0
+ source = https://www.djangoproject.com/m/releases/1.7/Django-1.7.2.tar.gz
+ md5sums = 855a53a9a5581c62b6031c9b3bd80ec5
+ sha256sums = 31c6c3c229f8c04b3be87e6afc3492903b57ec8f1188a47b6ae160d90cf653c8
pkgname = python-django
depends = python
+ depends = python-setuptools
optdepends = python-psycopg2: for PostgreSQL backend
pkgname = python2-django
depends = python2
+ depends = python2-setuptools
optdepends = mysql-python: for MySQL backend
optdepends = python2-psycopg2: for PostgreSQL backend
conflicts = django
diff --git a/PKGBUILD b/PKGBUILD
index e8bae47e7bb8..b00f98d3498b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=django
pkgname=('python-django' 'python2-django')
-pkgver=1.7.1
+pkgver=1.7.2
pkgrel=1
pkgdesc="A high-level Python Web framework that encourages rapid development and clean design"
arch=('any')
@@ -12,8 +12,8 @@ license=('BSD')
url="http://www.djangoproject.com/"
makedepends=('python2' 'python2-setuptools' 'python' 'python-setuptools')
source=("https://www.djangoproject.com/m/releases/${pkgver:0:3}/Django-$pkgver.tar.gz")
-md5sums=('81dae89f21647b9aa5c46c6b7dbfa349')
-sha256sums=('3de62e71ce2cfbcdecb6e344cad04948506c8410ea5c6eab15c8f3b31b8ac1c0')
+md5sums=('855a53a9a5581c62b6031c9b3bd80ec5')
+sha256sums=('31c6c3c229f8c04b3be87e6afc3492903b57ec8f1188a47b6ae160d90cf653c8')
prepare() {
cp -a "$srcdir/Django-$pkgver" "$srcdir/Django-$pkgver-python2"
@@ -31,7 +31,7 @@ build() {
}
package_python-django() {
- depends=('python')
+ depends=('python' 'python-setuptools')
optdepends=('python-psycopg2: for PostgreSQL backend')
cd "$srcdir/Django-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
@@ -49,7 +49,7 @@ package_python-django() {
}
package_python2-django() {
- depends=('python2')
+ depends=('python2' 'python2-setuptools')
optdepends=('mysql-python: for MySQL backend'
'python2-psycopg2: for PostgreSQL backend')
replaces=('django')