summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelix2015-09-15 14:44:28 +0200
committerfelix2015-09-15 14:44:28 +0200
commitffd8604e687ea527caaa9d4785e84f5f04c25892 (patch)
tree8ed935e99b7735dc0dd0a8fb6e519afabfe33bb9
parentafbbc8e7a6c17b77a2510f2afab501223ae18044 (diff)
downloadaur-ffd8604e687ea527caaa9d4785e84f5f04c25892.tar.gz
Fix build
-rw-r--r--PKGBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa6b5559e690..37b33e973058 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,28 +17,20 @@ options=(!strip) # makepkg will mistakenly try to use ELF binutils on COFF archi
_target_alias='i686-pc-msdosdjgpp'
prepare() {
- # This fixes programs crashing when compiled with -O2; more such kludges may be needed.
- # I wonder, though, why the linker won't just use $PREFIX/lib/ldscripts/i386go32.*?
- # It seems good enough, and more up-to-date.
- sed -i -e 's/\*(\.text)/*(.text) *(.text.*)/' "$srcdir/lib/djgpp.djl"
+ sed -ie 's/\*(\.text)/*(.text) *(.text.*)/' "$srcdir/lib/djgpp.djl"
+ sed -ie 's/gets(response);/fgets(response, sizeof(response), stdin);/' "$srcdir/src/stub/stubedit.c"
+ sed -ie 's/-m486//' "$srcdir/cross/makefile"
}
build() {
cd "$srcdir"
- # This only compiles the stubify and stubedit utilities. The standard library is
- # provided in this package only as headers+binaries. If you wish to compile them
- # yourself, look at the djlsr package. And good luck, because that code looks like
- # it hasn't been updated since gcc 2 came out.
- #
- # Some programs may also require exe2coff, but you can replace it by objcopy. It's
- # in the djgpp-binutils package.
make -f cross/makefile stub CFLAGS="$CFLAGS"
}
package() {
- install -Dm755 "$srcdir/src/stub/stubify" "$pkgdir/usr/$_target_alias/bin/stubify"
- install -Dm755 "$srcdir/src/stub/stubedit" "$pkgdir/usr/$_target_alias/bin/stubedit"
+ install -Dm755 "$srcdir/stubify" "$pkgdir/usr/$_target_alias/bin/stubify"
+ install -Dm755 "$srcdir/stubedit" "$pkgdir/usr/$_target_alias/bin/stubedit"
mkdir -p "$pkgdir/usr/bin"
ln -s "../$_target_alias/bin/stubify" "$pkgdir/usr/bin/$_target_alias-stubify"
ln -s "../$_target_alias/bin/stubedit" "$pkgdir/usr/bin/$_target_alias-stubedit"