summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Lane2015-06-09 17:35:04 +0100
committerJohn Lane2015-06-09 17:35:04 +0100
commitf7fbf718a2c71c9126849aa7677ab618cb704c8a (patch)
treef6cdb077dfc4c78f5237c11114703fb2421115ba
downloadaur-f7fbf718a2c71c9126849aa7677ab618cb704c8a.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD40
-rw-r--r--djmount.confd2
-rwxr-xr-xdjmount.rcd39
-rw-r--r--libupnp-1.6.9-JonimusPrime.diff11
5 files changed, 116 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46fcb40f1f50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = djmount
+ pkgdesc = A UPnP AV client that mounts media server contents as a filesystem.
+ pkgver = 0.71
+ pkgrel = 4
+ url = http://djmount.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = fuse
+ depends = libupnp
+ depends = talloc
+ source = http://downloads.sourceforge.net/sourceforge/djmount/djmount-0.71.tar.gz
+ source = http://ftp.de.debian.org/debian/pool/main/d/djmount/djmount_0.71-3.diff.gz
+ source = djmount.rcd
+ source = djmount.confd
+ source = libupnp-1.6.9-JonimusPrime.diff
+ md5sums = c922753e706c194bf82a8b6ca77e6a9a
+ md5sums = 00c5b6df865c8ffcd29b37de6f5503bf
+ md5sums = f473b5150df385447f2f58049bfb6199
+ md5sums = 21de4c947c17e8558f1007a20757f254
+ md5sums = c5c86bef5573dada1d1cd38b64b557c8
+
+pkgname = djmount
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5efbe065f6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Erik Johnson <palehose at gmail dot com>
+# Maintainer: Soup <soup a.t soultrap d.o.t n.e.t>
+# Contributor: Michele Schäuble <mschaeuble@swissonline.ch>
+
+pkgname=djmount
+pkgver=0.71
+pkgrel=4
+_debpatch=3
+pkgdesc="A UPnP AV client that mounts media server contents as a filesystem."
+arch=('i686' 'x86_64')
+url="http://djmount.sourceforge.net/"
+license=('GPL')
+depends=('fuse' 'libupnp' 'talloc')
+source=("http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
+ "http://ftp.de.debian.org/debian/pool/main/d/$pkgname/${pkgname}_$pkgver-$_debpatch.diff.gz"
+ 'djmount.rcd'
+ 'djmount.confd'
+ 'libupnp-1.6.9-JonimusPrime.diff')
+md5sums=('c922753e706c194bf82a8b6ca77e6a9a'
+ '00c5b6df865c8ffcd29b37de6f5503bf'
+ 'f473b5150df385447f2f58049bfb6199'
+ '21de4c947c17e8558f1007a20757f254'
+ 'c5c86bef5573dada1d1cd38b64b557c8')
+
+build() {
+ cd $srcdir
+ patch -p0 < "${pkgname}_$pkgver-$_debpatch.diff"
+ patch -p0 < "$pkgname-$pkgver/debian/patches/000_djmount.1.diff"
+ patch -p0 < "$pkgname-$pkgver/debian/patches/001-libupnp-1.6.6.diff"
+ patch -p0 < "$srcdir/libupnp-1.6.9-JonimusPrime.diff"
+
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --with-external-talloc --with-external-libupnp --with-libupnp-prefix=/usr
+ make
+ make DESTDIR=$pkgdir install
+
+ install -D -m755 $srcdir/djmount.rcd $pkgdir/etc/rc.d/djmount
+ install -D -m644 $srcdir/djmount.confd $pkgdir/etc/conf.d/djmount
+ install -D -m644 "$srcdir/$pkgname-$pkgver/djmount.1" ${pkgdir}/usr/share/man/man1/djmount.1
+}
diff --git a/djmount.confd b/djmount.confd
new file mode 100644
index 000000000000..079100e21c1e
--- /dev/null
+++ b/djmount.confd
@@ -0,0 +1,2 @@
+OPTIONS="-o ro,allow_other"
+MOUNTPOINT="/media/upnp"
diff --git a/djmount.rcd b/djmount.rcd
new file mode 100755
index 000000000000..84899dddbb8c
--- /dev/null
+++ b/djmount.rcd
@@ -0,0 +1,39 @@
+#!/bin/bash
+
+ . /etc/rc.conf
+ . /etc/rc.d/functions
+
+# source application-specific settings
+[ -f /etc/conf.d/djmount ] && . /etc/conf.d/djmount
+
+ case "$1" in
+
+ start)
+ stat_busy "Starting djmount"
+ /usr/bin/djmount $OPTIONS $MOUNTPOINT &>/dev/null
+ if [ $? -ne 0 ]; then
+ stat_fail
+ else
+ add_daemon djmount
+ stat_done
+ fi
+ ;;
+
+ stop)
+ stat_busy "Stopping djmount"
+ fusermount -u $MOUNTPOINT
+ kill -9 `pidof /usr/bin/djmount` &>/dev/null
+ rm_daemon djmount
+ stat_done
+ ;;
+
+ restart)
+ stat_busy "Restarting djmount ..."
+ $0 stop
+ $0 start
+ stat_done
+ ;;
+
+ *)
+ echo "usage: $0 {start|stop|restart}"
+ esac
diff --git a/libupnp-1.6.9-JonimusPrime.diff b/libupnp-1.6.9-JonimusPrime.diff
new file mode 100644
index 000000000000..cb3348a4375a
--- /dev/null
+++ b/libupnp-1.6.9-JonimusPrime.diff
@@ -0,0 +1,11 @@
+djmount-0.71/djmount/upnp_util.h
+--- djmount-0.71/djmount/upnp_util.h 2010-11-15 14:05:13.966692446 -0600
++++ djmount-0.71/djmount/upnp_util.h 2010-11-15 14:03:34.446692447 -0600
+@@ -28,6 +28,7 @@
+
+
+ #include <upnp/upnptools.h>
++#include <upnp/upnp.h>
+
+
+ #ifdef __cplusplus