summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Liu2019-01-25 11:29:03 +1100
committerJonathan Liu2019-01-25 11:29:03 +1100
commitbf8d6a61701a4b131e50fd2b535bc681f903eb98 (patch)
tree7494100a9ded3020540c31bb70ab619734f1fab1
parentccf5d27e2b76906f0bdc5fda120b6f6be3603854 (diff)
downloadaur-bf8d6a61701a4b131e50fd2b535bc681f903eb98.tar.gz
Update to 1.2.5-2
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
-rw-r--r--ffmpeg.patch111
3 files changed, 2 insertions, 115 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49e973032557..d11188fd03d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = djv
pkgdesc = Movie playback and image processing software for the film and computer animation industries
pkgver = 1.2.5
- pkgrel = 1
+ pkgrel = 2
url = http://djv.sourceforge.net/
arch = i686
arch = x86_64
@@ -18,7 +18,6 @@ pkgbase = djv
depends = libtiff
depends = openexr
depends = qt5-base
- options = !docs
source = git://git.code.sf.net/p/djv/git#tag=1.2.5
source = djv_view.desktop
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1b4d1b7d2085..9ded5dff03f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
# Contributer: N30N <archlinux@alunamation.com>
pkgname=djv
pkgver=1.2.5
-pkgrel=1
+pkgrel=2
pkgdesc="Movie playback and image processing software for the film and computer animation industries"
url="http://djv.sourceforge.net/"
license=('BSD')
arch=('i686' 'x86_64')
depends=("desktop-file-utils" "ffmpeg" "glew" "libjpeg" "libpng" "libquicktime" "libtiff" "openexr" "qt5-base")
makedepends=("cmake" "portaudio" "qt5-tools")
-options=("!docs")
source=("git://git.code.sf.net/p/djv/git#tag=1.2.5"
"${pkgname}_view.desktop")
md5sums=('SKIP'
diff --git a/ffmpeg.patch b/ffmpeg.patch
deleted file mode 100644
index 3e0f640c49b6..000000000000
--- a/ffmpeg.patch
+++ /dev/null
@@ -1,111 +0,0 @@
---- a/plugins/djvFFmpegPlugin/djvFFmpeg.cpp
-+++ b/plugins/djvFFmpegPlugin/djvFFmpeg.cpp
-@@ -90,7 +90,7 @@ djvFFmpeg::Packet::Packet()
-
- djvFFmpeg::Packet::~Packet()
- {
-- av_free_packet(&_p);
-+ av_packet_unref(&_p);
- }
-
- AVPacket & djvFFmpeg::Packet::operator () ()
---- a/plugins/djvFFmpegPlugin/djvFFmpeg.h
-+++ b/plugins/djvFFmpegPlugin/djvFFmpeg.h
-@@ -49,6 +49,7 @@ extern "C"
- #include <libavcodec/avcodec.h>
- #include <libavformat/avformat.h>
- #include <libavutil/dict.h>
-+#include <libavutil/imgutils.h>
- #include <libswscale/swscale.h>
-
- } // extern "C"
---- a/plugins/djvFFmpegPlugin/djvFFmpegLoad.cpp
-+++ b/plugins/djvFFmpegPlugin/djvFFmpegLoad.cpp
-@@ -164,7 +164,7 @@ void djvFFmpegLoad::open(const djvFileInfo & in, djvImageIoInfo & info)
- _avCodecContext->pix_fmt,
- _avCodecContext->width,
- _avCodecContext->height,
-- PIX_FMT_RGBA,
-+ AV_PIX_FMT_RGBA,
- SWS_BILINEAR,
- 0,
- 0,
-@@ -250,12 +250,14 @@ void djvFFmpegLoad::read(djvImage & image, const djvImageIoFrameInfo & frame)
- djvPixelData * data = frame.proxy ? &_tmp : &image;
- data->set(_info);
-
-- avpicture_fill(
-- (AVPicture *)_avFrameRgb,
-+ av_image_fill_arrays(
-+ _avFrameRgb->data,
-+ _avFrameRgb->linesize,
- data->data(),
-- PIX_FMT_RGBA,
-+ AV_PIX_FMT_RGBA,
- data->w(),
-- data->h());
-+ data->h(),
-+ 1);
-
- int f = frame.frame;
-
---- a/plugins/djvFFmpegPlugin/djvFFmpegSave.cpp
-+++ b/plugins/djvFFmpegPlugin/djvFFmpegSave.cpp
-@@ -234,11 +234,11 @@ void djvFFmpegSave::open(const djvFileInfo & fileInfo, const djvImageIoInfo & in
- avCodecContext->time_base.num = info.sequence.speed.duration();
-
- if (avFormat->flags & AVFMT_GLOBALHEADER)
-- avCodecContext->flags |= CODEC_FLAG_GLOBAL_HEADER;
-+ avCodecContext->flags |= AV_CODEC_FLAG_GLOBAL_HEADER;
-
- if (avQScale >= 0.0)
- {
-- avCodecContext->flags |= CODEC_FLAG_QSCALE;
-+ avCodecContext->flags |= AV_CODEC_FLAG_QSCALE;
- avCodecContext->global_quality = FF_QP2LAMBDA * avQScale;
- }
-
-@@ -305,17 +305,20 @@ void djvFFmpegSave::open(const djvFileInfo & fileInfo, const djvImageIoInfo & in
- _avFrame->format = avCodecContext->pix_fmt;
-
- _avFrameBuf = (uint8_t *)av_malloc(
-- avpicture_get_size(
-+ av_image_get_buffer_size(
- avCodecContext->pix_fmt,
- avCodecContext->width,
-- avCodecContext->height));
-+ avCodecContext->height,
-+ 1));
-
-- avpicture_fill(
-- (AVPicture *)_avFrame,
-+ av_image_fill_arrays(
-+ _avFrame->data,
-+ _avFrame->linesize,
- _avFrameBuf,
- avCodecContext->pix_fmt,
- avCodecContext->width,
-- avCodecContext->height);
-+ avCodecContext->height,
-+ 1);
-
- _avFrameRgb = av_frame_alloc();
-
-@@ -365,12 +368,14 @@ void djvFFmpegSave::write(const djvImage & in, const djvImageIoFrameInfo & frame
-
- // Encode the image.
-
-- avpicture_fill(
-- (AVPicture *)_avFrameRgb,
-+ av_image_fill_arrays(
-+ _avFrameRgb->data,
-+ _avFrameRgb->linesize,
- p->data(),
- _avFrameRgbPixel,
- p->w(),
-- p->h());
-+ p->h(),
-+ 1);
-
- quint64 pixelByteCount = p->pixelByteCount();
- quint64 scanlineByteCount = p->scanlineByteCount();