summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Liu2016-03-14 09:51:42 +1100
committerJonathan Liu2016-03-14 09:51:42 +1100
commitd3d762a570e01ae1124c2f1c38f4cd70b372ef0a (patch)
tree14d045ffcd7f8bc6ffdbd9b2299d1efd7cdfe6ee
parent6ab1e21fbac4f62c16bfad1f4286ba3f6e812ba8 (diff)
downloadaur-d3d762a570e01ae1124c2f1c38f4cd70b372ef0a.tar.gz
Update to 1.1.10-2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
-rw-r--r--ffmpeg.patch97
3 files changed, 106 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 840de0971186..0c8f2cef55c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sun Mar 13 22:50:34 UTC 2016
pkgbase = djv
pkgdesc = Movie playback and image processing software for the film and computer animation industries
pkgver = 1.1.0
- pkgrel = 1
+ pkgrel = 2
url = http://djv.sourceforge.net/
install = djv.install
arch = i686
@@ -21,8 +23,10 @@ pkgbase = djv
depends = qt5-base
options = !docs
source = git://git.code.sf.net/p/djv/git#commit=44a063755e627c70498d948478e29ffc1d3f105d
+ source = ffmpeg.patch
source = djv_view.desktop
md5sums = SKIP
+ md5sums = 9c16feff49d2b8af12f18a8346288e9e
md5sums = 2668ad2635036f33ba615b5dc538b1cf
pkgname = djv
diff --git a/PKGBUILD b/PKGBUILD
index 7e004be93dfc..33f9be3eae24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributer: N30N <archlinux@alunamation.com>
pkgname=djv
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Movie playback and image processing software for the film and computer animation industries"
url="http://djv.sourceforge.net/"
license=('BSD')
@@ -12,8 +12,10 @@ makedepends=("cmake" "portaudio" "qt5-tools")
options=("!docs")
install="${pkgname}.install"
source=("git://git.code.sf.net/p/djv/git#commit=44a063755e627c70498d948478e29ffc1d3f105d"
+ "ffmpeg.patch"
"${pkgname}_view.desktop")
md5sums=('SKIP'
+ '9c16feff49d2b8af12f18a8346288e9e'
'2668ad2635036f33ba615b5dc538b1cf')
prepare() {
@@ -21,6 +23,7 @@ prepare() {
sed -i '/enable_testing()/d' CMakeLists.txt
sed -i '/add_subdirectory(tests)/d' CMakeLists.txt
sed -i 's/set(djvPackageThirdParty true)/set(djvPackageThirdParty false)/' CMakeLists.txt
+ patch -Np1 -i "${srcdir}/ffmpeg.patch"
}
build() {
diff --git a/ffmpeg.patch b/ffmpeg.patch
new file mode 100644
index 000000000000..f4ac3b9b6763
--- /dev/null
+++ b/ffmpeg.patch
@@ -0,0 +1,97 @@
+--- a/plugins/djvFFmpegPlugin/djvFFmpeg.cpp
++++ b/plugins/djvFFmpegPlugin/djvFFmpeg.cpp
+@@ -90,7 +90,7 @@ djvFFmpeg::Packet::Packet()
+
+ djvFFmpeg::Packet::~Packet()
+ {
+- av_free_packet(&_p);
++ av_packet_unref(&_p);
+ }
+
+ AVPacket & djvFFmpeg::Packet::operator () ()
+--- a/plugins/djvFFmpegPlugin/djvFFmpeg.h
++++ b/plugins/djvFFmpegPlugin/djvFFmpeg.h
+@@ -49,6 +49,7 @@ extern "C"
+ #include <libavcodec/avcodec.h>
+ #include <libavformat/avformat.h>
+ #include <libavutil/dict.h>
++#include <libavutil/imgutils.h>
+ #include <libswscale/swscale.h>
+
+ } // extern "C"
+--- a/plugins/djvFFmpegPlugin/djvFFmpegLoad.cpp
++++ b/plugins/djvFFmpegPlugin/djvFFmpegLoad.cpp
+@@ -164,7 +164,7 @@ void djvFFmpegLoad::open(const djvFileInfo & in, djvImageIoInfo & info)
+ _avCodecContext->pix_fmt,
+ _avCodecContext->width,
+ _avCodecContext->height,
+- PIX_FMT_RGBA,
++ AV_PIX_FMT_RGBA,
+ SWS_BILINEAR,
+ 0,
+ 0,
+@@ -250,12 +250,14 @@ void djvFFmpegLoad::read(djvImage & image, const djvImageIoFrameInfo & frame)
+ djvPixelData * data = frame.proxy ? &_tmp : &image;
+ data->set(_info);
+
+- avpicture_fill(
+- (AVPicture *)_avFrameRgb,
++ av_image_fill_arrays(
++ _avFrameRgb->data,
++ _avFrameRgb->linesize,
+ data->data(),
+- PIX_FMT_RGBA,
++ AV_PIX_FMT_RGBA,
+ data->w(),
+- data->h());
++ data->h(),
++ 1);
+
+ int f = frame.frame;
+
+--- a/plugins/djvFFmpegPlugin/djvFFmpegSave.cpp
++++ b/plugins/djvFFmpegPlugin/djvFFmpegSave.cpp
+@@ -305,17 +305,20 @@ void djvFFmpegSave::open(const djvFileInfo & fileInfo, const djvImageIoInfo & in
+ _avFrame->format = avCodecContext->pix_fmt;
+
+ _avFrameBuf = (uint8_t *)av_malloc(
+- avpicture_get_size(
++ av_image_get_buffer_size(
+ avCodecContext->pix_fmt,
+ avCodecContext->width,
+- avCodecContext->height));
++ avCodecContext->height,
++ 1));
+
+- avpicture_fill(
+- (AVPicture *)_avFrame,
++ av_image_fill_arrays(
++ _avFrame->data,
++ _avFrame->linesize,
+ _avFrameBuf,
+ avCodecContext->pix_fmt,
+ avCodecContext->width,
+- avCodecContext->height);
++ avCodecContext->height,
++ 1);
+
+ _avFrameRgb = av_frame_alloc();
+
+@@ -365,12 +368,14 @@ void djvFFmpegSave::write(const djvImage & in, const djvImageIoFrameInfo & frame
+
+ // Encode the image.
+
+- avpicture_fill(
+- (AVPicture *)_avFrameRgb,
++ av_image_fill_arrays(
++ _avFrameRgb->data,
++ _avFrameRgb->linesize,
+ p->data(),
+ _avFrameRgbPixel,
+ p->w(),
+- p->h());
++ p->h(),
++ 1);
+
+ quint64 pixelByteCount = p->pixelByteCount();
+ quint64 scanlineByteCount = p->scanlineByteCount();