summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Gottula2023-10-22 16:49:44 -0700
committerJustin Gottula2023-10-22 16:49:44 -0700
commita63beb02226b793c8d2c96c6fedca6727662ddbc (patch)
treedb2c409e76322f1cc6dab441970d8a72800bde02
parent6f3768bfc5d525c3c141b12b3f247da496a0845a (diff)
downloadaur-a63beb02226b793c8d2c96c6fedca6727662ddbc.tar.gz
Update tarball checksum; add patch to fix the build on kernel 6.4+
-rw-r--r--PKGBUILD8
-rw-r--r--linux-6.4-compat.patch14
2 files changed, 20 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d26c15b83fd5..6cabbe043f32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Tom < reztho at archlinux dot us >
# Thanks to contributors/mantainers of frandom and dkms-nvidia packages
# since I used those packages as templates to make this one
+# Contributor: Justin Gottula <justin@jgottula.com>
pkgname=dkms-frandom
pkgver=1.2
-pkgrel=2
+pkgrel=3
pkgdesc="A very fast random number generator kernel module (DKMS version)"
arch=('any')
url="http://frandom.sourceforge.net/"
@@ -16,12 +17,14 @@ conflicts=("frandom")
options=(!strip)
_pkgname=frandom
source=("http://www.billauer.co.il/download/${_pkgname}-${pkgver}.tar.gz"
+'linux-6.4-compat.patch'
'frandom.udev.patch'
'dkms.conf'
'Makefile')
build() {
cd "$srcdir/$_pkgname-${pkgver}"
+ patch -p1 -i "$srcdir/linux-6.4-compat.patch"
patch -p1 -i "$srcdir/frandom.udev.patch"
}
@@ -33,7 +36,8 @@ package() {
install -m644 "$srcdir/Makefile" "$pkgdir/usr/src/$_pkgname-$pkgver"
}
-md5sums=('a4b60abb11799dda965694331e5b0785'
+md5sums=('4b862b8723ff9cedcab3a7c4feeaee42'
+ '7349887f821ad71795cfdafeb41f16fb'
'a41a534a4b732a6e2a0b41214fa27a1d'
'b8943c145912d5da71dd84e54465bb85'
'1e94254311f05274035b5e41ff5a7a33')
diff --git a/linux-6.4-compat.patch b/linux-6.4-compat.patch
new file mode 100644
index 000000000000..230075006f85
--- /dev/null
+++ b/linux-6.4-compat.patch
@@ -0,0 +1,14 @@
+--- original/frandom.c 2017-07-06 09:57:41.000000000 -0700
++++ modified/frandom.c 2023-10-22 16:38:32.867006422 -0700
+@@ -334,7 +334,11 @@ static int frandom_init_module(void)
+
+ erandom_seeded = 0;
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(6, 4, 0)
++ frandom_class = class_create("fastrng");
++#else
+ frandom_class = class_create(THIS_MODULE, "fastrng");
++#endif
+ if (IS_ERR(frandom_class)) {
+ result = PTR_ERR(frandom_class);
+ printk(KERN_WARNING "frandom: Failed to register class fastrng\n");