summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyak2015-06-08 16:52:31 +0300
committerkyak2015-06-08 16:52:31 +0300
commit0a168047aa00423d7026f72b7826874edc3f5617 (patch)
treebe5a9f630b28989c6b59012354035fbb09a0b1a8
downloadaur-0a168047aa00423d7026f72b7826874edc3f5617.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--Makefile16
-rw-r--r--PKGBUILD27
-rw-r--r--dkms.conf7
-rw-r--r--pl2501-driver.install40
-rw-r--r--pl2501.c122
6 files changed, 232 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..767bf9ed0b32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = dkms-pl2501
+ pkgdesc = DKMS-controlled kernel driver for PL-2501 USB Easy Trasfer Cables
+ pkgver = 20121021
+ pkgrel = 2
+ url = https://patchwork.kernel.org/patch/1227361/
+ install = pl2501-driver.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = linux-headers
+ depends = dkms
+ source = Makefile
+ source = dkms.conf
+ source = pl2501.c
+ md5sums = c34fe36014409a7522c55b94f831dd5d
+ md5sums = 2b5ea02f16debbd80827501262ee82ce
+ md5sums = e38e2c16893da59ab31889fb8b40c006
+
+pkgname = dkms-pl2501
+
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..dcb63618f060
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,16 @@
+obj-m := pl2501.o
+
+ifndef KERNELRELEASE
+KRELEASE := $(shell uname -r)
+else
+KRELEASE := $(KERNELRELEASE)
+endif
+
+KDIR := /usr/lib/modules/$(KRELEASE)/build
+PWD := $(shell pwd)
+
+default:
+ $(MAKE) -C $(KDIR) M=$(PWD) modules
+
+clean:
+ $(MAKE) -C $(KDIR) M=$(PWD) clean
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47d60e9a333a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=dkms-pl2501
+_pkgname=pl2501
+pkgver=20121021
+pkgrel=2
+pkgdesc='DKMS-controlled kernel driver for PL-2501 USB Easy Trasfer Cables'
+url='https://patchwork.kernel.org/patch/1227361/'
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('dkms')
+makedepends=('linux-headers')
+
+source=('Makefile'
+ 'dkms.conf'
+ 'pl2501.c')
+md5sums=('c34fe36014409a7522c55b94f831dd5d'
+ '2b5ea02f16debbd80827501262ee82ce'
+ 'e38e2c16893da59ab31889fb8b40c006')
+
+install=pl2501-driver.install
+
+package() {
+ cd "${srcdir}"
+ mkdir -p ${pkgdir}/usr/src/${_pkgname}-${pkgver}
+ cp -L Makefile ${pkgdir}/usr/src/${_pkgname}-${pkgver}
+ cp -L dkms.conf ${pkgdir}/usr/src/${_pkgname}-${pkgver}
+ cp -L pl2501.c ${pkgdir}/usr/src/${_pkgname}-${pkgver}
+}
diff --git a/dkms.conf b/dkms.conf
new file mode 100644
index 000000000000..0546a1ea4a91
--- /dev/null
+++ b/dkms.conf
@@ -0,0 +1,7 @@
+PACKAGE_NAME="pl2501"
+PACKAGE_VERSION="20121021"
+MAKE[0]="make"
+CLEAN="make clean"
+BUILT_MODULE_NAME[0]="pl2501"
+DEST_MODULE_LOCATION[0]="/kernel/drivers/net/usb"
+AUTOINSTALL="yes"
diff --git a/pl2501-driver.install b/pl2501-driver.install
new file mode 100644
index 000000000000..f49237cdd466
--- /dev/null
+++ b/pl2501-driver.install
@@ -0,0 +1,40 @@
+post_install() {
+ DKMS=`which dkms 2>/dev/null`
+
+ echo ">>> DKMS: Module add, build, and install"
+
+ $DKMS add -m pl2501 -v 20121021
+ $DKMS build -m pl2501 -v 20121021
+ $DKMS install -m pl2501 -v 20121021
+ modprobe pl2501
+
+ /sbin/depmod -a
+
+ cat <<EOF
+EOF
+}
+
+pre_upgrade() {
+ pre_remove
+}
+
+pre_remove() {
+ DKMS=`which dkms 2>/dev/null`
+ echo ">>> DKMS: Module uninstall"
+
+ line=`$DKMS status -m pl2501`
+ if echo "$line" | grep -E 'added|built|installed'; then
+ version=`echo "$line" | sed "s/pl2501,\([^,]*\)[,:].*/\1/;t;d"`
+ $DKMS remove -m pl2501 -v $version --all
+ fi
+
+ /sbin/depmod -a
+
+}
+
+post_upgrade() {
+ cd lib/modules
+ for i in extramodules-*; do depmod $(cat "$i/version"); done
+ cd ../..
+}
+
diff --git a/pl2501.c b/pl2501.c
new file mode 100644
index 000000000000..137d0626621c
--- /dev/null
+++ b/pl2501.c
@@ -0,0 +1,122 @@
+/*
+ * PL-2501 USB host-to-host link cables
+ * Copyright (C) 2000-2005 by David Brownell
+ * Copyright (C) 2012 by others
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
+#include <linux/module.h>
+#include <linux/init.h>
+#include <linux/netdevice.h>
+#include <linux/etherdevice.h>
+#include <linux/ethtool.h>
+#include <linux/workqueue.h>
+#include <linux/mii.h>
+#include <linux/usb.h>
+#include <linux/usb/usbnet.h>
+
+/*
+ * Bits 0-4 can be used for software handshaking; they're set from
+ * one end, cleared from the other, "read" with the interrupt byte.
+ */
+#define PL2501_S_EN (1<<7) /* (feature only) suspend enable */
+/* reserved bit -- rx ready (6) ? */
+#define PL2501_TX_READY (1<<5) /* (interrupt only) transmit ready */
+#define PL2501_RESET_OUT (1<<4) /* reset output pipe */
+#define PL2501_RESET_IN (1<<3) /* reset input pipe */
+#define PL2501_TX_C (1<<2) /* transmission complete */
+#define PL2501_TX_REQ (1<<1) /* transmission received */
+#define PL2501_PEER_E (1<<0) /* peer exists */
+
+static inline int
+pl2501_vendor_req(struct usbnet *dev, u8 req, u8 val, u8 index)
+{
+ return usb_control_msg(dev->udev,
+ usb_rcvctrlpipe(dev->udev, 0),
+ req,
+ USB_DIR_IN | USB_TYPE_VENDOR | USB_RECIP_DEVICE,
+ val, index,
+ NULL, 0,
+ USB_CTRL_GET_TIMEOUT);
+}
+
+static inline int
+pl2501_clear_QuickLink_features(struct usbnet *dev, int val)
+{
+ return pl2501_vendor_req(dev, 1, (u8) val, 0);
+}
+
+static inline int
+pl2501_set_QuickLink_features(struct usbnet *dev, int val)
+{
+ return pl2501_vendor_req(dev, 3, (u8) val, 0);
+}
+
+static int pl2501_reset(struct usbnet *dev)
+{
+ int status;
+
+ /* some units seem to need this reset, others reject it utterly.
+ * FIXME be more like "naplink" or windows drivers.
+ */
+ status = pl2501_set_QuickLink_features(dev,
+ PL2501_S_EN|PL2501_RESET_OUT|PL2501_RESET_IN|PL2501_PEER_E);
+ if (status != 0 && netif_msg_probe(dev))
+ netif_dbg(dev, link, dev->net, "pl2501_reset --> %d\n", status);
+ return 0;
+}
+
+static const struct driver_info prolific_info = {
+ .description = "Prolific PL-2501",
+ .flags = FLAG_POINTTOPOINT | FLAG_NO_SETINT,
+ /* some PL-2302 versions seem to fail usb_set_interface() */
+ .reset = pl2501_reset,
+};
+
+
+/*-------------------------------------------------------------------------*/
+
+/*
+ * Proilific's name won't normally be on the cables, and
+ * may not be on the device.
+ */
+
+static const struct usb_device_id products [] = {
+
+{
+ USB_DEVICE(0x067b, 0x2501), /* (PL-2501) */
+ .driver_info = (unsigned long) &prolific_info,
+},
+
+ { }, // END
+};
+MODULE_DEVICE_TABLE(usb, products);
+
+static struct usb_driver pl2501_driver = {
+ .name = "pl2501",
+ .id_table = products,
+ .probe = usbnet_probe,
+ .disconnect = usbnet_disconnect,
+ .suspend = usbnet_suspend,
+ .resume = usbnet_resume,
+ .disable_hub_initiated_lpm = 1,
+};
+
+module_usb_driver(pl2501_driver);
+
+MODULE_AUTHOR("David Brownell and others");
+MODULE_DESCRIPTION("Prolific PL-2501 USB Host to Host Link Driver");
+MODULE_LICENSE("GPL");