summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMickael FALCK2015-06-16 10:25:00 +0200
committerMickael FALCK2015-06-16 10:25:00 +0200
commit8145abe8ea7aed11462a0ec7d477e765c1f0b12e (patch)
tree35d51c60dba1256392f15a4f346358e54fdeb9b5
downloadaur-8145abe8ea7aed11462a0ec7d477e765c1f0b12e.tar.gz
Initial import from aur3
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--dl-cli.install7
-rw-r--r--use_python2.patch6
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5f2c2549f3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dl-cli
+ pkgdesc = Command line tool for submitting files into 'dl' download ticket service
+ pkgver = 0.12
+ pkgrel = 1
+ url = http://www.thregr.org/~wavexx/software/dl/
+ install = dl-cli.install
+ arch = any
+ license = GPL2
+ depends = python2>=2.7
+ depends = python2-pycurl
+ source = https://github.com/wavexx/dl/archive/dl-0.12.tar.gz
+ source = use_python2.patch
+ md5sums = 380e05aa8f0049ced1e988857bca0ca3
+ md5sums = cc4936b3fd56320e96568bbe5c8fb290
+
+pkgname = dl-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2f898abddb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mickaël 'lastmikoi' Falck <lastmikoi+abs@lastmikoi.net>
+pkgname=dl-cli
+pkgver=0.12
+pkgrel=1
+pkgdesc="Command line tool for submitting files into 'dl' download ticket service"
+arch=('any')
+url="http://www.thregr.org/~wavexx/software/dl/"
+license=('GPL2')
+depends=('python2>=2.7' 'python2-pycurl')
+install=dl-cli.install
+source=("https://github.com/wavexx/dl/archive/dl-$pkgver.tar.gz"
+ "use_python2.patch")
+md5sums=('380e05aa8f0049ced1e988857bca0ca3'
+ 'cc4936b3fd56320e96568bbe5c8fb290')
+
+prepare() {
+ patch -u "$srcdir/dl-dl-$pkgver/client/dl-cli.py" use_python2.patch
+}
+
+package() {
+ # This superfluous «dl-» is strange...
+ cd "$srcdir/dl-dl-$pkgver"
+
+ install -D -T ./client/dl-cli.py "$pkgdir/usr/bin/dl-cli"
+}
diff --git a/dl-cli.install b/dl-cli.install
new file mode 100644
index 000000000000..07315744ae22
--- /dev/null
+++ b/dl-cli.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo "Please read
+ http://www.thregr.org/~wavexx/software/dl/README.html#command-line-client-dl-cli
+ for instructions about client configuration.
+
+ You'll need a properly configured ~/.dl.rc file in order to use this software."
+}
diff --git a/use_python2.patch b/use_python2.patch
new file mode 100644
index 000000000000..17f0a48f4235
--- /dev/null
+++ b/use_python2.patch
@@ -0,0 +1,6 @@
+@@ -1,4 +1,4 @@
++#!/usr/bin/env python2
+-#!/usr/bin/env python
+ import ConfigParser
+ import base64
+ import pycurl