summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent2015-07-06 01:26:25 +0200
committerVincent2015-07-06 01:26:25 +0200
commit78ed8b7d4818855124c9d8d81cac652ce326e0ef (patch)
treeae81ec4958379796b92d527a67b645eb4ff08a24
downloadaur-78ed8b7d4818855124c9d8d81cac652ce326e0ef.tar.gz
Initial import
-rw-r--r--.AURINFO22
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD44
-rw-r--r--tests-remove.patch12
4 files changed, 102 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..1c2c74ea10e8
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,22 @@
+pkgbase = dl-fldigi-git
+ pkgdesc = Tracking Program for UK HAB Launches by James Coxon
+ pkgver = DL3.1.r245.g501f869
+ pkgrel = 2
+ url = https://github.com/jamescoxon/dl-fldigi
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = fltk
+ depends = libsamplerate
+ depends = libpng
+ optdepends = pulseaudio: pulseaudio support
+ optdepends = xmlrpc-c-abyss: XML-RPC control
+ optdepends = hamlib: rig control through hamlib
+ optdepends = portaudio: PortAudio support
+ optdepends = libsndfile: sound file support
+ provides = dl-fldigi
+ source = git+https://github.com/jamescoxon/dl-fldigi.git
+ source = tests-remove.patch
+
+pkgname = dl-fldigi-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d33931abfc1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = dl-fldigi-git
+ pkgdesc = Tracking Program for UK HAB Launches by James Coxon
+ pkgver = DL3.1.r245.g501f869
+ pkgrel = 2
+ url = https://github.com/jamescoxon/dl-fldigi
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = fltk
+ depends = libsamplerate
+ depends = libpng
+ optdepends = pulseaudio: pulseaudio support
+ optdepends = xmlrpc-c-abyss: XML-RPC control
+ optdepends = hamlib: rig control through hamlib
+ optdepends = portaudio: PortAudio support
+ optdepends = libsndfile: sound file support
+ provides = dl-fldigi
+ source = git+https://github.com/jamescoxon/dl-fldigi.git
+ source = tests-remove.patch
+ md5sums = SKIP
+ md5sums = 52f9d57f01db48e35c2e8a1d28d70fd4
+
+pkgname = dl-fldigi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43b65fa287a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+pkgname=dl-fldigi-git
+_gitname="dl-fldigi"
+pkgver=DL3.1.r245.g501f869
+pkgrel=2
+provides=('dl-fldigi')
+pkgdesc="Tracking Program for UK HAB Launches by James Coxon"
+arch=('i686' 'x86_64')
+url="https://github.com/jamescoxon/dl-fldigi"
+license=('GPL')
+depends=('fltk' 'libsamplerate' 'libpng')
+optdepends=('pulseaudio: pulseaudio support'
+#'cty: callsign database support'
+'xmlrpc-c-abyss: XML-RPC control'
+'hamlib: rig control through hamlib'
+'portaudio: PortAudio support'
+'libsndfile: sound file support')
+source=('git+https://github.com/jamescoxon/dl-fldigi.git' 'tests-remove.patch')
+md5sums=('SKIP' '52f9d57f01db48e35c2e8a1d28d70fd4')
+
+pkgver() {
+ cd "$_gitname"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$_gitname"
+ git checkout DL3.1
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd "$_gitname"
+ patch -Np1 -i "${srcdir}/tests-remove.patch"
+ autoreconf -vfi
+ ./configure --disable-flarq --enable-optimizations=native --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_gitname"
+ make DESTDIR="$pkgdir" install
+}
+
diff --git a/tests-remove.patch b/tests-remove.patch
new file mode 100644
index 000000000000..6459c5d6761b
--- /dev/null
+++ b/tests-remove.patch
@@ -0,0 +1,12 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 3b1e28a..56ce8bb 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -226,7 +226,6 @@ hamlib-static: $(dl_fldigi_OBJECTS)
+ endif
+ endif
+
+-TESTS = $(srcdir)/../scripts/tests/config-h.sh $(srcdir)/../scripts/tests/cr.sh
+
+ if HAVE_ASCIIDOC
+ $(builddir)/../doc/guide.html: $(builddir)/../doc/guide.txt