summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordiced2022-05-19 20:51:35 -0700
committerdiced2022-05-19 20:51:35 -0700
commit98a725368b766046467ccf391051c37e94407ad2 (patch)
tree410b710a8ab9f3dc713a06aab9bbf3dcf975f320
downloadaur-98a725368b766046467ccf391051c37e94407ad2.tar.gz
0.1.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD19
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d8dda3d4a2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = dlauncher
+ pkgdesc = An application launcher for Linux that is based on Ulauncher
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/diced/dlauncher
+ arch = x86_64
+ license = GPL3
+ makedepends = rust
+ makedepends = cargo
+ provides = dlauncher
+ conflicts = dlauncher
+ conflicts = dlauncher-bin
+ source = https://github.com/diced/dlauncher/releases/download/v0.1.0/dlauncher
+ source = https://github.com/diced/dlauncher/releases/download/v0.1.0/dlauncher-toggle
+ sha256sums = bb030a62642afbf11dc1b68a85d11ebd986f7418dae53ee346874c5927c1ba0a
+ sha256sums = 205441344af36652562e5d9664b5358779046eb843321f4a306e702432fd1ed5
+
+pkgname = dlauncher
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..adc5d0f12320
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname='dlauncher'
+pkgver=0.1.0
+pkgrel=1
+makedepends=('rust' 'cargo')
+conflicts=('dlauncher' 'dlauncher-bin')
+provides=('dlauncher')
+arch=('x86_64')
+pkgdesc="An application launcher for Linux that is based on Ulauncher"
+url="https://github.com/diced/dlauncher"
+source=("$url/releases/download/v$pkgver/dlauncher" "$url/releases/download/v$pkgver/dlauncher-toggle")
+sha256sums=('bb030a62642afbf11dc1b68a85d11ebd986f7418dae53ee346874c5927c1ba0a' '205441344af36652562e5d9664b5358779046eb843321f4a306e702432fd1ed5')
+license=('GPL3')
+
+package() {
+ cd "$srcdir" || exit 1
+
+ install -D -o root -g root -m 755 dlauncher "$pkgdir/usr/bin/dlauncher"
+ install -D -o root -g root -m 755 dlauncher-toggle "$pkgdir/usr/bin/dlauncher-toggle"
+} \ No newline at end of file