summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYoungjae Lee2021-07-04 21:57:47 +0900
committerYoungjae Lee2021-07-04 21:57:47 +0900
commit3dd4329efb4a0664a78038f0d5bcecd1ff7c4ba8 (patch)
tree57a05a8a7db6955d3601d533b33b41cdb4a329a2
downloadaur-3dd4329efb4a0664a78038f0d5bcecd1ff7c4ba8.tar.gz
Initial commit: 2.1.3-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..efce05ccb9bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = dm-zoned-tools
+ pkgdesc = User space utility for managing zoned block devices used with the dm-zoned device mapper
+ pkgver = 2.1.3
+ pkgrel = 1
+ url = https://github.com/westerndigitalcorporation/dm-zoned-tools
+ arch = x86_64
+ license = GPL3
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = libtool
+ makedepends = autoconf-archive
+ depends = glibc
+ depends = util-linux-libs
+ depends = kmod
+ depends = device-mapper
+ source = dm-zoned-tools-2.1.3.tar.gz::https://github.com/westerndigitalcorporation/dm-zoned-tools/archive/refs/tags/v2.1.3.tar.gz
+ md5sums = d836ee377d17235710c06b07fc747da3
+
+pkgname = dm-zoned-tools
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcf05ebc4fe9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Youngjae Lee <ls4154.lee@gmail.com>
+pkgname=dm-zoned-tools
+pkgver=2.1.3
+pkgrel=1
+pkgdesc="User space utility for managing zoned block devices used with the dm-zoned device mapper "
+arch=("x86_64")
+url="https://github.com/westerndigitalcorporation/dm-zoned-tools"
+license=("GPL3")
+depends=("glibc" "util-linux-libs" "kmod" "device-mapper")
+makedepends=("autoconf" "automake" "libtool" "autoconf-archive")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/westerndigitalcorporation/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+md5sums=("d836ee377d17235710c06b07fc747da3")
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./autogen.sh
+ ./configure --prefix=/usr --sbindir='${exec_prefix}/bin'
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}