summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-08 20:36:24 +0200
committerStefan Husmann2015-06-08 20:36:24 +0200
commitfc58a9ab8a6933b270ad97d8a5a6a15269a1850b (patch)
treea67e1475e5ea5340d50d5f336bfef7e8016426a9
downloadaur-fc58a9ab8a6933b270ad97d8a5a6a15269a1850b.tar.gz
initial version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f36d30b6af09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dmake
+ pkgdesc = A make utility similar to GNU make or the Workshop dmake, formerly used by the OpenOffice.org build system.
+ pkgver = 4.12.2
+ pkgrel = 1
+ url = http://tools.openoffice.org/dmake/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ source = https://dmake.apache-extras.org.codespot.com/files/dmake-4.12.2.tar.bz2
+ md5sums = 9194f727c31d1db18bf5dd02e7b2dd09
+
+pkgname = dmake
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55a1c5183e45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Pablo Nicolas Diaz <pablonicolas.diaz at gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=dmake
+pkgver=4.12.2
+pkgrel=1
+pkgdesc="A make utility similar to GNU make or the Workshop dmake, formerly used by the OpenOffice.org build system."
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://tools.openoffice.org/dmake/index.html"
+depends=('glibc')
+source=(https://dmake.apache-extras.org.codespot.com/files/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('9194f727c31d1db18bf5dd02e7b2dd09')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --enable-spawn
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
+