summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Dray2015-07-05 18:12:08 +1000
committerJustin Dray2015-07-05 18:12:08 +1000
commit64f884b72dbc9a7188b59394ec99a812e089b394 (patch)
tree8e5d11a65fea762418d46bcc8a46b89d5d24114f
downloadaur-64f884b72dbc9a7188b59394ec99a812e089b394.tar.gz
Update to: r16.177fd14-1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD22
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9329723f04e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dmakepkg-git
+ pkgdesc = Makepkg running from within docker for clean builds without maintaining a chroot
+ pkgver = r16.177fd14
+ pkgrel = 1
+ url = https://github.com/justin8/docker-makepkg
+ arch = any
+ license = MIT
+ depends = docker
+ options = !emptydirs
+ source = git+https://github.com/justin8/docker-makepkg.git
+ md5sums = SKIP
+
+pkgname = dmakepkg-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..181b3460e424
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+*
+!PKGBUILD
+!.SRCINFO
+!*.patch
+!*.desktop
+!*.install
+!*.service
+!*.sh
+!*.conf
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2754cd6003f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Justin Dray <justin@dray.be>
+
+pkgname=dmakepkg-git
+pkgver=r16.177fd14
+pkgrel=1
+pkgdesc='Makepkg running from within docker for clean builds without maintaining a chroot'
+arch=('any')
+url="https://github.com/justin8/docker-makepkg"
+license=('MIT')
+depends=('docker')
+options=(!emptydirs)
+source=(git+https://github.com/justin8/docker-makepkg.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd docker-makepkg
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm755 "${srcdir}/docker-makepkg/dmakepkg" "${pkgdir}//usr/bin/dmakepkg"
+}