summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorniQo2015-06-16 13:06:18 +0200
committerniQo2015-06-16 13:06:18 +0200
commite57caec87269e433fabb212169a9e2554b47a838 (patch)
treec42aa9bf8ff1b91ffca3eebb718d2e87741be5fc
downloadaur-e57caec87269e433fabb212169a9e2554b47a838.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
-rw-r--r--dmapd.install3
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a671fd68bbb7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = dmapd
+ pkgdesc = Serve DAAP (iTunes) and DPAP (iPhoto) shares from Linux
+ pkgver = 0.0.72
+ pkgrel = 1
+ url = http://www.flyn.org/projects/dmapd/
+ install = dmapd.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libdmapsharing>=2.9.21
+ depends = graphicsmagick
+ depends = libexif
+ depends = vips>=7.36
+ depends = gst-plugins-base-libs
+ optdepends = gst-plugins-ugly: Extra media codecs
+ options = !libtool
+ backup = etc/dmapd.conf
+ source = http://www.flyn.org/projects/dmapd/dmapd-0.0.72.tar.gz
+ md5sums = 0fe290d1bf003296b1ed9dfcc0108d6f
+
+pkgname = dmapd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55177cdd1307
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Nicolas QuiƩnot < niQo at aur >
+# Contributor: Alan Orth <alan.orth@gmail.com>
+
+pkgname=dmapd
+pkgver=0.0.72
+pkgrel=1
+pkgdesc="Serve DAAP (iTunes) and DPAP (iPhoto) shares from Linux"
+arch=('i686' 'x86_64')
+url="http://www.flyn.org/projects/dmapd/"
+license=('GPL')
+depends=('libdmapsharing>=2.9.21' 'graphicsmagick' 'libexif' 'vips>=7.36' 'gst-plugins-base-libs')
+makedepends=()
+optdepends=('gst-plugins-ugly: Extra media codecs')
+options=('!libtool')
+backup=('etc/dmapd.conf')
+source=("http://www.flyn.org/projects/$pkgname/$pkgname-$pkgver.tar.gz")
+install=dmapd.install
+md5sums=('0fe290d1bf003296b1ed9dfcc0108d6f')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+
+ # fix username in default config
+ sed -i 's/User=dmapd/User=daemon/' distro/dmapd.conf
+
+ # create cache directories
+ install -d ${pkgdir}/var/cache/dmapd || return 1
+ install -d ${pkgdir}/var/cache/dmapd/DAAP || return 1
+ install -d ${pkgdir}/var/cache/dmapd/DPAP || return 1
+
+ # copy distribution files
+ install -D -m 0644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING" || return 1
+ install -D -m 0644 distro/dmapd.conf ${pkgdir}/etc/dmapd.conf || return 1
+ install -D -m 0755 distro/dmapd.service ${pkgdir}/usr/lib/systemd/system/dmapd.service || return 1
+}
+
diff --git a/dmapd.install b/dmapd.install
new file mode 100644
index 000000000000..4229ddb4fbe3
--- /dev/null
+++ b/dmapd.install
@@ -0,0 +1,3 @@
+post_install() {
+ chown -R daemon:daemon var/cache/dmapd &>/dev/null
+}