summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmiel Kollof2020-05-06 13:42:21 +0200
committerEmiel Kollof2020-05-06 13:42:21 +0200
commit4b6416170fa47293bc27d5b2274d00706d085656 (patch)
treeca5bd1b4bac859e6965a57eebe828bb97f5b7b5a
downloadaur-4b6416170fa47293bc27d5b2274d00706d085656.tar.gz
Fist commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD47
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ba6137e32ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = dmenu-ekollof-git
+ pkgdesc = Emiel Kollof's personal patched build of dmenu.
+ pkgver = 4.9.r2.b87e7ec
+ pkgrel = 1
+ url = https://git.hackerheaven.org/ekollof/dmenu-ekollof.git
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = sh
+ depends = ttf-twemoji-color
+ depends = ttf-joypixels
+ depends = dbus
+ depends = libxft-bgra
+ depends = libx11
+ depends = libxinerama
+ depends = libxext
+ depends = freetype2
+ provides = dmenu
+ conflicts = dmenu
+ source = git+https://git.hackerheaven.org/ekollof/dmenu-ekollof.git
+ md5sums = SKIP
+
+pkgname = dmenu-ekollof-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..876b26ecadf7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Emiel Kollof <emiel@kollof.nl>
+pkgname=dmenu-ekollof-git
+pkgver=4.9.r2.b87e7ec
+pkgrel=1
+epoch=
+pkgdesc="Emiel Kollof's personal patched build of dmenu."
+arch=(x86_64)
+url="https://git.hackerheaven.org/ekollof/dmenu-ekollof.git"
+license=('MIT')
+groups=()
+depends=(sh ttf-twemoji-color ttf-joypixels dbus libxft-bgra libx11 libxinerama libxext freetype2)
+makedepends=(git)
+checkdepends=()
+optdepends=()
+provides=(dmenu)
+conflicts=(dmenu)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "dmenu-ekollof"
+ printf "4.9.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "dmenu-ekollof"
+ make > /dev/null
+}
+
+package() {
+ cd "dmenu-ekollof"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}