summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackson McCrory2021-01-05 21:49:11 -0800
committerJackson McCrory2021-01-05 21:49:11 -0800
commit3f766d3382f92cd20456f00a6b8cfcfcb714a95b (patch)
treea6eaacf69b23bdd901de72b1992445f6dd652a82
downloadaur-3f766d3382f92cd20456f00a6b8cfcfcb714a95b.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD48
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7543a763844
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dmenu-jadecell-git
+ pkgdesc = JadeCell's build of dmenu patched for caseinsensitive, instant, lineheight, etc.
+ pkgver = 5.0.r2.6bf6160.r..r..r.
+ pkgrel = 1
+ url = https://gitlab.com/jadecell/dmenu.git
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ provides = dmenu
+ conflicts = dmenu
+ source = git+https://gitlab.com/jadecell/dmenu.git
+ md5sums = SKIP
+
+pkgname = dmenu-jadecell-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c07c012285ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Jackson McCrory <jackson@mccrory.xyz>
+pkgname=dmenu-jadecell-git
+pkgver=5.0.r2.6bf6160.r..r..r.
+pkgrel=1
+epoch=
+pkgdesc="JadeCell's build of dmenu patched for caseinsensitive, instant, lineheight, etc."
+arch=(x86_64 i686)
+url="https://gitlab.com/jadecell/dmenu.git"
+license=('MIT')
+groups=()
+depends=()
+makedepends=(git)
+checkdepends=()
+optdepends=()
+provides=(dmenu)
+conflicts=(dmenu)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "${pkgver}.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd dmenu
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+}
+
+package() {
+ cd dmenu
+ mkdir -p ${pkgdir}/opt/${pkgname}
+ cp -rf * ${pkgdir}/opt/${pkgname}
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}