summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShizcow2020-07-10 22:35:03 -0600
committerShizcow2020-07-10 22:35:03 -0600
commit14ca944ebf9980b910e499584c1bfcf581856125 (patch)
treee8b70eef1da9e0b49b34c00beda8ca9964ef5b96
parent3da85a8d9b13e9c89347294fb395cafd745ca935 (diff)
downloadaur-14ca944ebf9980b910e499584c1bfcf581856125.tar.gz
Upstream: Version bump correctly
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11b12ea9ccfb..12dc0644114c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dmenu-rs-git
pkgdesc = The development branch of dmenu-rs. Likely has unstable features.
- pkgver = 5.3.0.r241.47084d1
+ pkgver = 5.3.1.r244.a46cdc7
pkgrel = 1
url = https://github.com/Shizcow/dmenu-rs
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 0048a9ba1ef9..d794e41f105c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,7 +30,7 @@ makedepends=('rust' 'git' 'clang' 'sh')
_pkgname=dmenu
_pkgbase=$_pkgname-rs
pkgname=$_pkgbase-git
-pkgver=5.3.0.r241.47084d1
+pkgver=5.3.1.r244.a46cdc7
pkgrel=1
pkgdesc="The development branch of dmenu-rs. Likely has unstable features."
arch=('i686' 'x86_64')
@@ -43,17 +43,18 @@ md5sums=('SKIP')
pkgver() {
cd $_pkgbase
- # first get the most recent tag from master
- git checkout master > /dev/null
- git describe --tags | tr -d '\n'
- # then get the commit hash from development branch
git checkout develop > /dev/null
+ # first get the version number
+ cat config.mk | grep "VERSION" | grep -Po '(\d+\.)?(\d+\.)?(\*|\d+)' | tr -d '\n'
+ # then get the commit hash from development branch
printf ".r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() (
cd $_pkgbase
git config advice.detachedHead false
+ git checkout develop > /dev/null
+ git pull
)
build() (