summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShizcow2020-07-02 21:38:27 -0600
committerShizcow2020-07-02 21:38:27 -0600
commitbcefee3384d1e23aef7c2711f1e8113be039b81c (patch)
treec879474ff004d12004fde3e7812145b03bc89aa0
parentbd1e0c7c8428e2e71dc226269f084ddbc979f26b (diff)
downloadaur-bcefee3384d1e23aef7c2711f1e8113be039b81c.tar.gz
Updated dependencies
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
2 files changed, 19 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4dac5f2146fe..289d26e0736b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,9 +9,10 @@ pkgbase = dmenu-rs-git
makedepends = rust
makedepends = git
makedepends = clang
- depends = sh
- depends = libxinerama
depends = libxft
+ depends = xclip
+ depends = aspell
+ depends = libxinerama
provides = dmenu
conflicts = dmenu
source = dmenu-rs::git+https://github.com/Shizcow/dmenu-rs.git
diff --git a/PKGBUILD b/PKGBUILD
index 11ebad3ce1aa..e1cf2913aa09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,6 +8,22 @@
# or run `make plugins` in the cloned repo
PLUGINS=""
+
+# -------------------------------------------------------
+# DEPENDS
+# -------------------------------------------------------
+# If you want a super-minimal system, some of the following
+# dependencies can be disabled
+# Always required:
+depends=('libxft')
+# Required for plugins which copy to clip perminantly
+# this includes: calc, spellcheck
+depends+=('xclip')
+# Requred for the spellcheck plugin
+depends+=('aspell')
+# Required for Xinerama (requires editing config.mk to disable)
+depends+=('libxinerama')
+
_pkgname=dmenu
_pkgbase=$_pkgname-rs
pkgname=$_pkgbase-git
@@ -17,7 +33,6 @@ pkgdesc="The development branch of dmenu-rs. Likely has unstable features."
arch=('i686' 'x86_64')
url="https://github.com/Shizcow/dmenu-rs"
license=('GPL')
-depends=('sh' 'libxinerama' 'libxft')
makedepends=('rust' 'git' 'clang')
provides=($_pkgname)
conflicts=($_pkgname)